Binutils 2.17 is released

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The GNU Binutils 2.17 has been released.

I'm preparing to download it and try it out in my experimental avr toolchain right now. But while I wait...

Does anybody have any first-hand knowledge regarding 2.17's level of AVR support?

- 2.16 has to be patched to support many of the newer parts, such as ATmega48/88/168 which I use on a regular basis. Has support for those devices been included in this most recent release? If not, will the patches for 2.16 work on 2.17?

- There is an experimental set of patches to allow development of code for the ATmega256x. Can the relevant patches be adapted to work on 2.17?

- Luke

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

> Does anybody have any first-hand knowledge
> regarding 2.17's level of AVR support?

Didn't try it myself yet, but it should be fairly up-to-date. Maybe
it lacks support of the new picopower devices, but anything else is
supposed to be supported out of the box.

> There is an experimental set of patches to allow development of code
> for the ATmega256x. Can the relevant patches be adapted to work on
> 2.17?

That patch was kind of a "moving target" patch, so I'd expect it to
require some work.

I'll see to update my FreeBSD port of avr-binutils within the next
days, and if some devices (like the picopower ones) are missing,
there'll be a new "newdevices" patch then.

Jörg Wunsch

Please don't send me PMs, use email if you want to approach me personally.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lfmorrison wrote:
The GNU Binutils 2.17 has been released.

- 2.16 has to be patched to support many of the newer parts, such as ATmega48/88/168 which I use on a regular basis. Has support for those devices been included in this most recent release? If not, will the patches for 2.16 work on 2.17?

- Luke

I've used 2.16.1 and it works for Mega168:s without patching ... So my guess is that 2.17 should be OK "out of the box" ...