Avrstudio4 crashes on startup

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Dear all:

I have a problem with astudio4 which crashes on startup, It seems to be a faulty or missing win98 dll, since when I click in the avrstudio icon, an error window pops up complaining:

AVRSTUDIO provocó un error de página no válida en el
módulo AVRSTUDIO.EXE de 0167:00404e04.
Registros:
EAX=00000000 CS=0167 EIP=00404e04 EFLGS=00010202
EBX=006c6840 SS=016f ESP=008ef294 EBP=006c5b9c
ECX=00000000 DS=016f ESI=0050a278 FS=3b7f
EDX=008ef294 ES=016f EDI=29400003 GS=0000
Bytes en CS:EIP:
,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x ,02x
Volcado de pila:
,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x

This is not the first time it happens to me but last time I was forced to reinstall win98 and only then I was able to run the program (previous deletion of the Windows dir).

Can anyone of you tell me how can I solve this problem, or better, which SYSTEM DLL's Astudio4 actually uses?. I've checked the system integrity with the win98 system tools, but there were no missing or corrupted files.

Thanks in advance

Nachus

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I don't know how much ram you have, but I used to have a problem trying to run Studio 4.07. in fact I could not run it at all, untill I got an extra 96M of ram (192M now) for another application and then Studio started to run.

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have never been able to run any of the Studio 4x IDEs on my NT4 system (I only run NT4 because I have to!!). I have 128M of memory, so I borrowed another 128M to try it and I still can't run Studio 4 (3.56 works great). The strange thing is that the error message changes. I went back to 128M and the error message reverts to what it was before.
As I now need to run CVAVR, staying with 3x is a problem.

Any suggestions anyone?

with 128M memory -

AVRStudio.exe
Exception: access violation (0xc0000005), Address: 0x6c374060

DrWatson dump -

eax=11050302 ebx=0000012c ecx=0012f188 edx=0012ef70 esi=0012e5f8 edi=0012ef70
eip=6c374060 esp=0012e5cc ebp=0052cce0 iopl=0 nv up ei pl nz na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000 efl=00000202

function: Ordinal858
6c374041 8bf1 mov esi,ecx
6c374043 8b0e mov ecx,[esi] ds:0012e5f8=0012f188
6c374045 8b07 mov eax,[edi] ds:0012ef70=11050302
6c374047 3bc8 cmp ecx,eax
6c374049 7434 jz Ordinal858+0x44 (6c37407f)
6c37404b 8379f400 cmp dword ptr [ecx-0xc],0x0 ds:0125db8e=00000000
6c37404f 7d0f jge Ordinal858+0x25 (6c374060)
6c374051 83c1f4 add ecx,0xf4
6c374054 3b0d5c1c446c ds:6c441c5c=6c441c4c
cmp ecx,[Ordinal6378+0x1854 (6c441c5c)]
6c37405a 0f85ee7b0500 jne Ordinal539+0x4f (6c3cbc4e)
FAULT ->6c374060 8378f400 cmp dword ptr [eax-0xc],0x0 ds:1217ed08=????????
6c374064 0f8ce47b0500 jl Ordinal539+0x4f (6c3cbc4e)
6c37406a 8bce mov ecx,esi
6c37406c e808fbffff call Ordinal5513 (6c373b79)
6c374071 8b07 mov eax,[edi] ds:0012ef70=11050302
6c374073 8906 mov [esi],eax ds:0012e5f8=0012f188
6c374075 83c0f4 add eax,0xf4
6c374078 50 push eax
6c374079 ff15bcb1406c ds:6c40b1bc=77f050f0
call dword ptr [Ordinal636+0xe11 (6c40b1bc)]
6c37407f 8bc6 mov eax,esi
6c374081 5f pop edi
6c374082 5e pop esi

............................................................................................

with 256M memory -

AVRStudio.exe
Exception: hardcoded breakpoint (0x80000003), Address: 0x77f762e8

DrWatson dump -

eax=00000000 ebx=00000000 ecx=00000001 edx=ffffffff esi=00000000 edi=00131dd4
eip=77f762e9 esp=0246ffac ebp=0246ffb8 iopl=0 nv up ei ng nz na po nc
cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000 efl=00000286

function: DbgBreakPoint
77f762e8 cc int 3
FAULT ->77f762e9 c3 ret
77f762ea 8bc0 mov eax,eax

admin's test signature
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Any idea why everybody blames the lack of memory for all their PC incidents? Could be Billy Gates's work?! Talkin' about Windoze, what is
the version of Internet Explorer you are using? If it is 4.0 (should be, if you cleanly installed Win98) DO install the latest version (5.0+, please).
It usually installs all the newest DLLs you may need.
Remember to install IE 5.0+ after every reinstallation of Win98, or else...

Good luck!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Try install Microsoft XML Parser (MSXML).

[http://msdn.microsoft.com/downlo...