AVRISP Firmware problem

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Freaks,

We use the stk500.exe in a command line script with an AVRISP for production programming. I recently upgraded my version of AVRStudio from v4.08 to v4.11. AVRStudio then prompted me to upgrade the firmware on my AVRISP, which I did. Now I'm finding that the newly upgraded AVRISP won't work with the older version of stk500.exe. I've tried un-installing v4.11 and re-installing v4.08 with the plan of down-grading the AVRISP firmware, but now the application just hangs when I try to access the AVRISP.
Anyone know how to fix this?

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The newer studio uses version 2 protocol. Can you use the new version of STK500.exe (which I presume also uses V2 protocol)? Else you may have to manually downgrade to the older version of the firmware. (stk500.ebn)

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

John,

Thanks for your reply. Could you please explain how to do a manual downgrade..

Cheers
Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Search the forums (here or in the AVR GCC Forum). This has been discussed before.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

From memory it may be DN10 or DN11 in the academy.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly