avrdude done - no activity and no errors

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've been using avrdude and an avrisp mkii on Windows 10 to program stuff for ages. Suddenly a couple of days ago, I turned the computer on and ran avrdude as usual, but I got an error about libusb0.dll missing. I've not changed anything, and I've dug through every event viewer entry and can't find any reason for this to suddenly stop working as it always has.

 

I managed to fix the dll error (for anyone else wondering, the x64 libusb0.dll file is NOT the one you need - you actually need to get the libusb0_x86.dll file, rename it to libusb0.dll and then put that in the syswow64 folder), and now when I run avrdude, the only line I get is 'avrdude done. Thank you.' without even attempting to run anything. Without an error message of some sort, I'm unsure what I'm supposed to be trying to fix - is it a Windows issue, a dll issue, avrdude issue, arvisp driver issue, hardware issue, or USB driver issue? Fixing the dll error is just treating a symptom, I need to find what caused it to change it's behaviour.

 

I've tried to run it on an old computer which is an offline machine (so it definitely hasn't had any windows updates lately), and it gives the same dll error. Putting the correct file in the syswow64 folder removes the error and I get the same lack of output. Yet on someone else's computer with the same setup, it works fine. I've tested with their programmer and cables and everything, and I even got them to send me all of their files and put them in all the right places, yet I still get the error. There doesn't seem to be any reason for it to suddenly stop working, and since it seems I can't install it on another computer, there's no point trying a full reformat either.

 

Hopefully someone here knows what's going on.