AVR32 Studio 1.0 Beta released on atmel.com

Go To Last Post
12 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

AVRStudio is based on Eclipse and runs on Linux natively as well as Windows.
(Atmel is making me want to move to Norway to be nearer these awesome Atmel people :) )

Last Edited: Tue. Apr 3, 2007 - 12:48 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Know how you feel man, know how you feel. It even has a sexy damn logo XD;;

-S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I start the "Create an AVR32 Linux Project" tutorial, but building of the application fails:

**** Build of configuration Debug for project HelloWorld ****

make -k all
Building file: ../hello.c
Invoking: AVR32/GNU Linux C Compiler
avr32-linux-gcc -g3 -c -fmessage-length=0 -Wall -O0 -mpart=ap7000 -MMD -MP -MF"hello.d" -MT"hello.d" -o"hello.o" "../hello.c"
make: *** [hello.o] Error 57
make: Target `all' not remade because of errors.
Build complete for project HelloWorld

What is the trouble?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does the command avr32-linux-gcc -g3 -c -fmessage-length=0 -Wall -O0 -mpart=ap7000 -MMD -MP -MF"hello.d" -MT"hello.d" -o"hello.o" "../hello.c" succeed out side of A32S? If not, then it is a toolchain issue and you might need a reinstall. If it does, then it would seem A32S is at fault, it would be nice to know what error 57 is!

-S.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The command avr32-linux-gcc -g3 -c -fmessage-length=0 -Wall -O0 -mpart=ap7000 -MMD -MP -MF"hello.d" -MT"hello.d" -o"hello.o" "../hello.c" doesn't work outside AVR32S too. The problem is in quotes (""). When I replace it with avr32-linux-gcc -g3 -c -fmessage-length=0 -Wall -O0 -mpart=ap7000 -MMD -MP -MF'hello.d' -MT'hello.d' -o'hello.o' '../hello.c' all begin working properly. But I can't do it in AVR32S. The workaround is using internal AVR32S builder.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You say that "The workaround is using internal AVR32S builder." Does that mean that you did not create a "managed make" project as the tutorial say you shall?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No. It doesn't. I create the "Managed make AVR32 C project" following the tutorial. But building the project fails. After that I explore the project options and set the checkbox "Enable internal builder".

P.S. Also when I add the include libraries (-l) linker option it doesn't take any effect.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok, I'll look into that. Thank you for your report.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It seems that the problems lies in "make", which version are you using and does the path to your workspace contain space characters?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

1. make v-
GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for i686-pc-cygwin

2. The path to workspace is "c:\temp\HelloWorld" and not contains space characters.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Torkild,

The WinAVR Makefile Template uses these flags to generate dependencies:

# Compiler flags to generate dependency files.
GENDEPFLAGS = -MMD -MP -MF .dep/$(@F).d

Perhaps AVR32 Studio should be changed to match.

Eric Weddington