AVR to viewfinder interface

Go To Last Post
12 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

what's the part called you look through at an old analog video camera (the part where you see the b/w picture of what you are going to record).

I'm trying to interface such a part with an AVR. With my DVM i figured out which pin is which signal. First i thought the signal would be a standard video signal (composite video, ntsc or pal). I've tried an PAL signal from an Mini-CMOS Camera but it was not working. Does anyone know which kind of signal is used here?

Attachment(s): 

Hava a look at my web page -> http://www.tobiscorner.at.tf

Last Edited: Tue. Jun 29, 2004 - 09:35 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've managed to get something on the screen, but the picture does move... I've tried PAL and NTSC timing but it's still not working...

Hava a look at my web page -> http://www.tobiscorner.at.tf

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If it is multi-pin and NOT coax, then it is probably "S-Video". The important parts are common, one line with a monochrome signal (sync pulses and luminance) and one line with the color subcarrier separated from the video.

Jim

Jim Wagner Oregon Research Electronics, Consulting Div. Tangent, OR, USA http://www.orelectronics.net

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It's one line GND, one line +5V, one Line -5V and one line video.

Hava a look at my web page -> http://www.tobiscorner.at.tf

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Then its not likely "standard" (unless its relatfively new with digital video, but you said its older).

Baseband video should be about 1V ppk from sync tip to top of luminance. Sync pulses are negative going and about 0.35V in amplitude. If it is AC (capacitor) coupled, it will appear to shift up and down in level, depending on the brightness in the scene.

Voltage-wise, NTSC and PAL are very similar and horizontal line time is very similar. Differences are in frame rate (60Hz vs 50Hz), number of lines per frame, color subcarrier frequency (3.56MHz vs 4.5MHz), the method of encoding color onto the subcarrier, and the arrangement of the sync pulses in the vertical retrace interval.

Jim

Jim Wagner Oregon Research Electronics, Consulting Div. Tangent, OR, USA http://www.orelectronics.net

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The device you are trying to interface is commonly called a 'viewfinder'.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What i got is a line that is moving down the screen. so there is something wrong with the frames. but i can draw as many rames as i want the line does move the same way.

Attachment(s): 

Hava a look at my web page -> http://www.tobiscorner.at.tf

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

At this point I would suspect that what ever signal you are using the sync seperator in the viewfinder is not seeing the field syncs and is free running above the normal field rate.

Keep it simple it will not bite as hard

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I will try a negitve sync level this afternoon, by now i used 0V as sync, 0.3V as black and 1V as white.

Hava a look at my web page -> http://www.tobiscorner.at.tf

Last Edited: Tue. Jun 29, 2004 - 09:36 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

how about connecting the viewfinder to the video output of a TV set or a videorecorder first?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've connected it to a CMOS Camera Module that produces a Video Signal. The camera does work with a TV but not with the viewfinder.

Hava a look at my web page -> http://www.tobiscorner.at.tf

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

O.k now it's working. I've connected the viewfinder with the video output of my brother digicam and i got the picture. So the field syncs is not generated correct with my AVR.

Thanks for your help

Hava a look at my web page -> http://www.tobiscorner.at.tf