AVR Sturdio loads a project, shows yellow arrow and axits.

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have a problem with AVR Studio

I have a Pentium computer running XP SP2.
I have installed AVR Studio 4.11 with SP3 on top.

My problem is that for some, but not all my programs I try to debug, AVR Studio loads the object file, sets the yellow arrow at the first executable line, and then exits before I can do anything.

To make the problem as simple as possible, I tried to simulate app note AVR100 on a tiny 26.

I assemled the AVR100 app note assembler program with studio, it also exited when I tried to debug (simulate) the program. But when I placed a breakpoint at the first instruction, and then selected start debugging it did not exit the AVR100 program.

When the object file is not generated by AVR Studio, but eg. CodeVision or WinAVR I can not set a breakpoint before AVR Studio exits.

Studio triggers an MFC error, but that dammed M$ error report dialog :evil: does not allow me to take a copy of the error report and paste it here.

It can be solved by taking multible print screens of the error dialog, and if no evident explantion exist I will deliver this number of print screens upon request.

I will be thankfull to receive help on this showstopper.

Erik