AVR Studio 5.1 BETA Released

Go To Last Post
34 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just released at:

Atmel Home > Microcontrollers > Atmel AVR 8- and 32-bit Microcontrollers > What's Changed (last 30 days)

Doc. Type    Title                                Date        Revision  Size
---------    -----                                ----        --------  ----
Software     AVR Studio 5.1 BETA installer        12/21/2011  5.1.148   308MB
Release Note AVR Studio 5.1 BETA Release Note     12/21/2011  5.1.148    71KB
Software     AVR Studio 5.1 BETA installer - Full 12/21/2011  5.1.148   523MB

Registration not required when downloading from this location.

Stan

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ATMEL--Heart Beat
Nothing Impossible

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

avrguru wrote:
Download from here: http://www.atmel.com/dyn/product...

That seems just very stupid. With the link sbennet supplied there is no registration needed. With the link you supplied registration is required.

So why should someone want to state, for more times that one keeps counts of, that ones name is "X", one lives at "X" etc, that ones job function is "Consultant", is a "Descision maker" and am expecting an annual volume of +10M devices - i.e. just trying to get through that totally idiotic repeated registration as fast as possible?

@avrguru: What are the advantages of using the link you supplied?

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

release notes wrote:
New command line utility (atprogram) with support for all Atmel AVR tools and devices
Wow. Does "all" mean all here?

release notes wrote:
New version of AVR Toolchain, version 3.3.1
If anybody from Atmel listens here: will this be available standalone?

JW

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Release Notes wrote:
Programming dialog can program from .elf files

Oooh, i might actually be able to uninstall avr studio 4 now.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Is it me or does the release note:

http://www.atmel.com/dyn/resourc...

suggest that none of the major problems that have been reported in this forum have been addressed?!? Perhaps things like "new toolchain" simply cover a multitude of sins?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:
Is it me or does the release note [...] suggest that none of the major problems that have been reported in this forum have been addressed?!?

Well, it lists "Notable bugs fixed", so they might've been seen as "not notable".

I'd like to give the toolchain a testride, anyway. Wonder, which version of avr-gcc does it employ.

JW

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

At last a Beta Ver!!! It better than nothing.
The question now is which of them is more beta? the V5 or the V5.1 Beta?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Against my better judgement I decided to download it but now I face the conundrum of:

Doc. Type    Title                                Date        Revision  Size
---------    -----                                ----        --------  ----
Software     AVR Studio 5.1 BETA installer        12/21/2011  5.1.148   308MB
Software     AVR Studio 5.1 BETA installer - Full 12/21/2011  5.1.148   523MB

How on earth does the 308MB version differ from the 523MB one. What does "Full" mean and what isn't "Full" about the smaller one?

I guess I'll regret it if I don't go for the 0.5GB file?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

On this page, http://www.atmel.com/dyn/product..., you'll see that the full install includes MS Visual Studio Shell and .NET 4.0. If you already have those you can go for the small one.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

AS 5.1 Download Direct Links

SMALL
http://www.atmel.com/dyn/resourc...

FULL with .NET4 and MS Visual Studio Shell
http://www.atmel.com/dyn/resourc...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Wonder, which version of avr-gcc does it employ.

Finally got it downloaded/installed (just 2.5 hours from my post above ;-)) and find:

gcc version 4.5.1 (AVR_8_bit_GNU_Toolchain_3.3.1_445)

EDIT: woo hoo! default optimisation for "Debug" is now -O1 not -O0. Result!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh well the euphoria quickly wore off...

(and what's happened to the previous options of "browse for source" or "proceed with disassembly only"?)

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No, the "debug-bug" is still there, but with a slightly different error text and the possibility to debug within the disass-listing, still not in C-Level.

But meanwhile I got a corrected dll-file from the support (I sent the desired Error log to them), with this dll everything is ok! :D :D :D

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

But meanwhile I got a corrected dll-file from the support (I sent the desired Error log to them), with this dll everything is ok!

Danv PM'd the DLL to me too and it seems to work for me as well (based on a small test).

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

peter9999 wrote:
But meanwhile I got a corrected dll-file from the support (I sent the desired Error log to them), with this dll everything is ok! :D :D :D

Good to hear the fix works for you and Cliff !

Here´s the fixed DLL for public consumption. Unpack and use it to replace the released one in

win32:
C:\Program Files\Atmel\AVR Studio 5.1\extensions\Application
win64
C:\Program Files (x86)\Atmel\AVR Studio 5.1\extensions\Application

It contains a small event scheduling change that I made in the summer for a customer with debug problems in a VM. The change didn´t get included in 5.1 beta due to last minute issues, but I will make sure a fix gets added to the next beta.

Edit: Somehow the archives I upload get corrupted after a while (!?). Try Cliff's link instead
http://www.wrightflyer.co.uk/Atm...

Dan

Last Edited: Sun. Dec 25, 2011 - 09:45 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

I made in the summer for a customer with debug problems in a VM.

Dan,

I probably haven't made this clear but I always run AS5 in a VirtualBox VM running Windows XP SP3. Maybe it's significant that a VM is involved? Probably worth asking people in future who are afflicted if they are using a VM.

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

danv wrote:
Here´s the fixed DLL for public consumption. Unpack and use it ...

Dan

Sorry to ask, but is that zip archive broken somehow? I can't unpack it.

Regards,
Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

scp wrote:
Sorry to ask, but is that zip archive broken somehow? I can't unpack it.

Darn, this was the same file I sent Cliff, downloaded from the Sent mailbox and reposted in this thread. Somehow the file got corrupt.
Sorry for the inconvenience :(

Edit: Somehow the archives I upload get corrupted after a while (!?). Try Cliff's link instead
http://www.wrightflyer.co.uk/Atm...

-dan

Last Edited: Sun. Dec 25, 2011 - 09:45 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

danv wrote:
Sorry for the inconvenience :(
No worries! :wink:

danv wrote:
Attaching a fresh archive.
Works fine now. Thank you!

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

scp wrote:
danv wrote:
Sorry for the inconvenience :(
No worries! :wink:

danv wrote:
Attaching a fresh archive.
Works fine now. Thank you!

Paul

Hi.
Not working again, at least for me.
Could you put it in some sharing site, please?
Thank you

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just tried to downaload and its not working

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Download does not work again. Why not use the update tab in v5.1 to sort this.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just saw this beta was released. I also just had my harddrive crash and lost all of my installed programs (data was mostly elsewhere). Can anyone give some input on whether I should just install AS5.1 Beta or AS5? I was pretty happy with AS5, issues aside.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

Can anyone give some input on whether I should just install AS5.1 Beta or AS5? I was pretty happy with AS5, issues aside.

With the software so "raw" and still in the early stages I think I'd always go for the "latest" even if it is described as "beta" (let's face it AS5.0 was too!). 5.1 has had about 6-8 months more development time than 5.0 so you'd sure hope that the ratio of bugs fixed to bugs newly introduced is better than 1:1 !

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Clawson,

Thanks, I'm tending to agree with that sentiment. I'm actually mostly ok with AS5, but that's probably because I'm not really doing much (...or any...) debugging, which seems to be causing most of the issues that I've seen. It also works well with ASF, which is pretty important to one of my projects (say what you will about ASF, and I'll probably agree, but it still gets the job done!).

I'll give this a shot, hopefully it doesn't blow my computer up...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just tried to export a project that i have been working on in studio 4 into studio 5.1 beta and get the following error

21:55:34: [ERROR] Failed to launch. Missing file: C:\My Projects\Razor\Razor_V1.00\Razor_V1.cof

I know the cof file exists as i have been debugging in V4 for some time now.

I used the import in V5.1 to create the project.

Any help would be appreciated

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@rev
I presume that you have created a project in AVRStudio 4 using Razor_V1.cof. If it is ture, try creating a new project in AVR Studio 5.1 using the menu, "File -> Open -> Open Object File for Debugging" and provide the same Razor_V1.cof as input to "Select the object File To Debug" text box

Regards,
Deena

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi tsgd84, you are correct, i created the avrstudio 4 project using the cof file. Just tried your suggestion and have the same result as described above

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

iwoloschin wrote:
I also just had my harddrive crash and lost all of my installed programs (data was mostly elsewhere)..
You're a techie and don't image your disk every week?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just tried importing another project that i have been working on with AS4 and get this.

# Communication server listening on port 52943.
18:48:44: [WARNING] DEBUG_TARGET Contains an additional node IO_EXPAND
18:48:44: [WARNING] DEBUG_TARGET Contains an additional node REGISTERNAMES
18:48:44: [WARNING] Skipped reading Files Information from source project. It is either invalid or not provided., ModuleName: ProjectImporter.Core
18:48:44: [WARNING] Skipped reading Build Dependency settings from source project. It is either invalid or not provided., ModuleName: ProjectImporter.Core
18:48:44: [WARNING] Skipped reading ProjectLevelToolchainSettings from source project. It is either invalid or not provided., ModuleName: ProjectImporter.Core
18:49:18: [ERROR] Failed to launch. Missing file: C:\Smart Openers\Projects\Nano_Series\Nano_Series_V4.03\Nano_Series_V4.cof

I give up

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Any comments from atmel here

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Any comments from atmel here

From the release notes of AVR Studio 5.1[5.1.148], http://www.atmel.com/dyn/resourc...

Contact Information
For support on AVR Studio 5 please contact avr@atmel.com

It might be helpful, if you could send the object file (*.cof) the one which you are trying to work with :)

Regards,
Deena