avr-objdump - No Disk (solved)

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Now, this doesn't seem to happen very often. I've only found one post (from 2003 by Tony Speidel) describing this problem, and it seems that the poor guy never got an answer.

https://www.avrfreaks.net/forum/problem-avr-objdump-conversion-lss-elf

 

The issue: When compiling (using AVR Toolchain), avr-objdump generates a weird "No Disk" error.

avr-objdump - No Disk

Just getting rid of the error window was difficult. It just kept reappearing, generating a single .lss file line every time.

 

As in Tony's case, the stuff kinda worked when I changed -S to -s in the makefile, but that just rendered the .lss file absolutely useless.

 

After wasting the better part of the morning, and growing extremely frustrated, I found the really simple solution. I deleted all output files (.o, .d, .hex, .elf and such), and then avr-objdump miraculously worked again. I imagine that 99% of you would have thought of this from the beginning, or your compilers are set up to clean automatically. But this is for the 1% (or maybe 0.01%) like myself.

 

Have a nice day.

 

 

You're absolutely right. This member is stupid. Please help.