AVR Dragon with AVRDUDE, Need Correct Port

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just bought a new AVR Dragon and I am trying to use it in ISP mode with AVRDUDE.

AVRDUDE decides to default to LPT1 as the port. I then use "-P usb" but it reports "avrdude: usbdev_open(): did not find any USB device "usb""

I opened Device Manager, my AVR Dragon is said to be under "Port_#0002.Hub_#0005" so I tried "-P usb:2" and many other combinations of 2 and 5. I always get "avrdude: usbdev_open(): did not find any (matching) USB device "usb:something""

I've searched Google and this forum and everybody seems to be using "-P usb" and it seems to work fine for people.

If it is relevant, I'm running Windows 7 Ultimate 64 bit, and have WinAVR-20100110 with AVRDUDE 5.10 . I have upgraded the Dragon's firmware to the latest supplied with AVR Studio 4.18

How can I get this really really expensive programmer to work with AVRDUDE?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you are in Windows why on earth are you trying to use avrdude? Use Studio, it's a great interface for both programming and debugging with the Dragon. If you want to script the process then use the Atmel command line tools in the Studio directory.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It works fine in AVR Studio, but I would like to solve this problem and see it work with avrdude. Please tell me, with the information provided, what do I need to put after the "-P"?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I guess you have to ask the libusb-win32 developers about the state
of their support for Windows 7. AVRDUDE cannot use your Dragon unless
libusb provides an access path to it. Note that libusb-win32 ships
with a small test program that displays the details about all devices
libusb can see on your bus; make sure you can recognize the AVR Dragon
within that output before continuing with AVRDUDE.

And yes, »-P usb« is the correct port name. Only if you've got more than
one device attached to the bus, you can qualify them with their serial
number in order to distinguish them (the last digits are sufficient),
as in »-P usb:42a5«.

Jörg Wunsch

Please don't send me PMs, use email if you want to approach me personally.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

frank26080115 wrote:
It works fine in AVR Studio, but I would like to solve this problem and see it work with avrdude. Please tell me, with the information provided, what do I need to put after the "-P"?

I experienced the same problem. Solution is to install libusb-win32

http://sourceforge.net/apps/trac/libusb-win32/wiki

-=Bryan=-

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

I experienced the same problem. This solution " libusb-win32" SEEMS to be good but :

the Comxx as disapeared (it's usb now) and i don't now how to configure -P option ("usb" is not correct).

And with this driver AVRStudio is not able to connect to the target board.

But be carefull, the driver doesn't want to desinstall (I tested the tool provided and other solutions). You have to reinstall it with reinstalling arduino Ide.

And, the Tera Term doesn't see the port "comxxx" now.

So, i think it's a risky solution.

Note : i'm on windows Xp pro