Attiny817 Xplained mini seen as Atmel USB Devices in Device Manager

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

 

I have problem with Attiny817 Xplained mini board. I used this board few months ago with Atmel Studio 7.0.1645 and it works fine. Now I installed Atmel Studio 7.0.1931 and launch and connect the board to the computer but it now installed as Atmel USB Devices Atmega 32U4. I don't have installed have mEDBG and COM port. So installed board isn't useful in Atmel Studio. Why this board now is installed as USB Device not mEDBG device.

This topic has a solution.
Last Edited: Sun. Sep 2, 2018 - 10:20 AM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It's in firmware upgrade mode. To get it out, do a manual fw upgrade.
.
In studio, go to tools/command prompt and issue 'atfw -t medbg -a /tools/mEDBG/medbg_fw.zip'.
.
Remember to substitute your installation directory...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for your help, your advice was helpful. But I have another problem in Atmel Studio 7.0.1931 when I want connect with programmer I get this error:

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

To fix that, see https://spaces.microchip.com/gf/project/avr_xp_mini/news/?id=75 and https://spaces.microchip.com/gf/project/avr_xp_mini/frs/?action=FrsReleaseView&release_id=433
.
It would also be nice if you could give me the real serial number of the kit, so that I can have a look at the production log and figure out what went wrong...
.
But, you did say that you had used it before? What did you do when it broke?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The serial number of my board is ATML265806180000234 and question mark on black background.

 

When I bought this board I used Atmel Studio 7.0.1645 with this version of Atmel Studio that board working fine. The software normally recognized the board despite the bad serial number. Later i put this board to the drawer because i played with STM32 and now I pulled it out and connect to the computer and she doesn't recognized as medbg device. I don't know what happened with her.

 

Serial from the box is:1800001822

2017.07.06

Made in Malaysia

A09-2656/06

Last Edited: Sun. Sep 9, 2018 - 05:38 PM