Atmel Studio 7 upgrade firmware EDGB MSD issue

Go To Last Post
16 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am using SAMD21J18A xplained dev kit. I am trying to upload an example code but its keep asking me to upgrade the firmware of the EDGB MSD. Even after upgrading that from the app it's asking me again 

I also tried repairing and reinstalling Atmel studio nothing helped.

I have tried manual upgrade from command prompt  as explained in this blog http://pic18f4520palakpatel.blog...

but it keeps crashing I have used both of these commands
 C:\Program Files (x86)\Atmel\Studio>atfw -t edbg ATML2130021800026369 -a "edbg_fw.zip"

C:\Program Files (x86)\Atmel\Studio>atfw -t edbg ATML2130021800026369 -a "medbg_fw.zip"

 

I am using windows 10, please help to resolve this issue.

thanks in advance

 

Attachment(s): 

This topic has a solution.
Last Edited: Mon. Nov 20, 2017 - 09:55 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In studio, go to Tools->View Available Tools, right click the EDBG, select Kit mode and set it to DGI (and persist). 

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for reply

I haven't tried that but I went to studio achieve an installed the June package. http://www.atmel.com/tools/studi...

make sure while installing uncheck the select box to which says Install the latest one. Now it works :)

 

I will try ur solution in future if I upgrade my studio.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:
In studio, go to Tools->View Available Tools, right click the EDBG, select Kit mode and set it to DGI (and persist). 

They really need to fix this...

"When all else fails, read the directions"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Folks,

 

I think I'm having exactly the same problem.  I'm running a fresh install of AS7 build 1645 (the latest).  However, under Tools, I have no option for "View Available Tools".  I can run atprogram and get info for my device (atprogram -t edbg -i swd -d atsamd21j18a info).

 

I'm running Windows 7 Pro, SP1

I only have one device/tool attached.

 

Correction:

When I searched for "Available Tools", I got that window and was able to select DGI mode from Kit Mode Selections (via right-click on the device).

 

This seem to be working now.

 

Last Edited: Wed. Dec 6, 2017 - 07:40 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Try resetting your window layout Window>Reset Window Layout:

"When all else fails, read the directions"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am having the same problem using a brand new Arduino Zero just bought this month from Arduino.cc. Mu older Zero bought from the same place 2 years ago upgraded fine but the new one is stuck in Firmware versio 2.01.

 

There's no option for kit mode to go to DGI on the EDBG right mouse click for this board, I'm figuring it must be stuck in the wrong mode, maybe a fuse setting. There was such an option, I think, with the SAMD21XPlained board.

 

Is there a way to fix this, maybe a command line utility or something? I'm using the latest Atmel Studio 7.0.1645 on Windows 10.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am having the same issue as Surfing Dude. I am trying to program a Arduino Zero and when I right click on the EDBG tool I do not get a Kit mode option.

When I try and program I see that something is sent to the Arduino and the window says it is successful but it does not actually program the firmware.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

bamsch wrote:
I am having the same issue as Surfing Dude

What is the error you are getting?

"When all else fails, read the directions"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I also can not see 'kit mode' on my debugger. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi 

I installed Atmel Studio 7 ,  there is no tool in the drop box , not in device programming page and not in the project configuration page .

I am using samd21 xplained pro board , and also when I connect the board , Atmel Studio can not recognize it is connected. 

I reinstalled Studio several times , even tried lower ver 6.2 , nothing helped .

Its four days that I am stuck , would you please kindly tel me what should I do ?

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

pgupta91 wrote:

I am using SAMD21J18A xplained dev kit. I am trying to upload an example code but its keep asking me to upgrade the firmware of the EDGB MSD. Even after upgrading that from the app it's asking me again 

I also tried repairing and reinstalling Atmel studio nothing helped.

I have tried manual upgrade from command prompt  as explained in this blog http://pic18f4520palakpatel.blog...

but it keeps crashing I have used both of these commands
 C:\Program Files (x86)\Atmel\Studio>atfw -t edbg ATML2130021800026369 -a "edbg_fw.zip"

C:\Program Files (x86)\Atmel\Studio>atfw -t edbg ATML2130021800026369 -a "medbg_fw.zip"

 

I am using windows 10, please help to resolve this issue.

thanks in advance

 

 

Please update https://s3-us-west-2.amazonaws.com/atmel-studio/7.0.1652/as-installer-7.0.1652-web.exe and provide your feedback.

Regards,

Charles

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I dont get an error. When I plug in my Atmel Arduino Zero it say I need to upgrade the EDBG software to continue. it show 2.01 on tool and 3.25 on  disk. When I select upgrade it comes back with EDBG firmware successfully upgraded but when I try to use it it is still at the 2.01 level.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

After reading back previous messages I updated the Atmel software to version 7.0.1652 and all is good now.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

thank you for the updated installer.
Now EDBG upgrade works on Windows 10 with Atmel Studio 7.0.1652

 

regards