Atmel ICE programmer won't work until a AT90USB1287 processor is connected via USB on the same pc

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hello together
I used over 10 years the avr studio 4 with the AVR jtag mkii.
Since some days my old programmer was defected and I bought the new jtag ICE.
but this is only working under the avr studio 7

I'm using now the command line tool "atprogram" to flash via batch file automatic in the production.
But I have the same issue like Zbig_T from this ticket: https://www.avrfreaks.net/forum/...

In case i connect my programmed device(AT90USB1287) via USB (what I urgent need) I get the same error messages below
Please help me as soon as possible because we have to flash high urgent many AT90USB1287 controller board in the production.
@Site Admin:Please send me the new "untested version" that fix the problem like you send to Zbig_T

thanks a lot!!

error messages from the atprogramm command line:

--------------------------------------------------------------------

Working...TCF channel terminated
error: [Errno 10054] An existing connection was forcibly closed by the remote host
  File "tcf\channel\AbstractChannel.py", line 69, in run
  File "tcf\channel\StreamChannel.py", line 61, in read
  File "tcf\channel\ChannelTCP.py", line 96, in getBuf
[ERROR] JSON error: Failed to parse response to  Tool:getAttachedTools: Command C Tool getAttachedTools aborted

------------------------------------------------------------------------------------------

C:\Users\Administrator\Documents>atprogram list
Working.  TCF channel terminated
error: [Errno 10054] Eine vorhandene Verbindung wurde vom Remotehost geschlossen
  File "tcf\channel\AbstractChannel.py", line 69, in run
  File "tcf\channel\StreamChannel.py", line 61, in read
  File "tcf\channel\ChannelTCP.py", line 96, in getBuf
[ERROR] JSON error: Failed to parse response to  Tool:getAttachedTools: Command C Tool getAttachedTools aborted

Atmel ICE programmer won't work until a AT90USB1287 processor is connected via USB on the same pc

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

thomas.vahrson wrote:

@Site Admin:Please send me the new "untested version" that fix the problem like you send to Zbig_T

 

But that fix was for a very specific problem to do with a specific laptop docking station. Are you sure that you have the same problem and not simply the same error message?

#1 Hardware Problem? https://www.avrfreaks.net/forum/...

#2 Hardware Problem? Read AVR042.

#3 All grounds are not created equal

#4 Have you proved your chip is running at xxMHz?

#5 "If you think you need floating point to solve the problem then you don't understand the problem. If you really do need floating point then you have a problem you do not understand."

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

i total agreee. it's not the same issue. but the same error message.

I have the problem directly until I connect my programmed /flashed controller from Atmel via USB.

 

I can see the Atmel jtage ICE programmer flasher in the device manager. But not in the AVR Studio 7 and over the command line.

I loose directly the programmer in the software but it's present in the device manager and I get exactly the same error message :(

 

thanks for your fast response.