atavrdragon avrdragon problem

1 post / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi. I have searched on topic about the avrdragon Debugger/programmer on the avr freaks forum, but there is not a lot of information about the problem I have. So, I started a new post.

I recently purchased the new ATAvrdragon from atmel, because I have a product running with an atmega168 and the only way to be able to debug it is with the Debugwire interface. All other debugwire debugger hardware are costly, but this one was really cheap...

So I purchased it. I have tried debugwire on mega168, ISP on mega168 and JTAG on mega32. The debugwire and ISP work fine. But when I try to start a debug session on an mega32, it not work...

all compile fine, transfert fine to the Dragon, and the cpu start working too. I dont know if the code is executed correctly, but it start. I have made this small program test; (the same for mega168 and mega32)

.include "m32def.inc"
.def temp=r18
.dseg

.cseg
.org $0000

jmp Reset ;Reset handler
reset:
ldi temp,255
rst1:
dec temp
rjmp rst1

In mega168, all is fine in step by step, the temp register is decreasing. But with the mega32, the step arrow on the left of avrstudio work, but the temp register value is always 0.

I suspect not a problem in the emulator, but a problem in avrstudio, because I have tried another bigger project, and the Step arrow in avrstudio work lineary in the code, without jumping to any JMP instruction...

Someone having the same problem??

I use the avrstudio SP4

AVR Studio 4.12.498 Service Pack 4
GUI Version 4, 12, 0, 491
AVR Dragon 1, 0, 1, 2
ATmega32 210

Operating System
Major 5
Minor 1
PlatformID 2
Build 2600
Service Pack 1

Plugins:

AvrPluginAvrAsmObject 1, 0, 0, 43
AvrPluginavrgccplugin 1, 0, 0, 6
Stk500Dll 1, 0, 1, 0

If there is no solution for the moment, I can live with that, because I have the jtagIce unit working. But I cant use it on my laptop, because I dont have serial port on it, and adapters rs232-USB dont work really good, crash often...

Thanks.

Cedric, www.innovativedevice.com