AS7 not installing

Go To Last Post
17 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Atmel Studio 7 is not installing on my Windows 7 64-bit machine.

 

An Error occured (sic)

Windows6.1-KB2999226-1.0-x64.msu

 

If try again  it just sits at the 'Installing...' stage with

     Overall progress: Applying

     Downloading - Windows6.1-KB2999226-1.0-x64.msu

 

If I re-boot and try again, it goes back to 'An Error occured', etc.

 

Tried three times now (with virus checker disabled) over the last week with as-installer-7.0.582-web.exe and later  with as-installer-7.0.594-web.exe

 

Has anyone else had this problem, and/or know how to solve it?

 

(edit: removed white space at end)

Attachment(s): 

This topic has a solution.
Last Edited: Fri. Nov 6, 2015 - 01:34 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi

 

Do a Windows update and if there are issues with Windows update please follow the below link to trouble shoot it.

 

How to check the Windows update installed in the machine ?
http://windows.microsoft.com/en-us/windows/which-windows-updates-installed

 

How to troubleshoot the Windows update mechanism?
http://windows.microsoft.com/en-us/windows/troubleshoot-problems-installing-updates

 

Regards,

Charles

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks Charles.

 

Windows update does seem to be having problems - updates failed when  i tried it this afternoon. I'll do as you suggest and investigate this first.  

 

(off topic: I wish i could use an Apple Mac for Atmel Studio)

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've installed all the windows updates and rebooted, but it's still failing in the same way

 

Log file attached. Relevant part seems to be:

...

[1F40:1F44][2015-10-21T11:40:38]i301: Applying execute package: Windows7_MSU_x64, action: Install, path: C:\ProgramData\Package Cache\94E1D328D6ED02A890CE3A0AF452367C7C8073CD\Windows6.1-KB2999226-1.0-x64.msu, arguments: '"C:\Windows\SysNative\wusa.exe" "C:\ProgramData\Package Cache\94E1D328D6ED02A890CE3A0AF452367C7C8073CD\Windows6.1-KB2999226-1.0-x64.msu" /quiet /norestart'

[1F40:1F44][2015-10-21T11:40:42]e000: Error 0x80240017: Failed to execute MSU package.
[1F50:1F54][2015-10-21T11:40:42]e000: Error 0x80240017: Failed to configure per-machine MSU package.
[1F50:1F54][2015-10-21T11:40:42]i000: VisualInstaller : Message: ExecutePackageComplete
[1F50:1F54][2015-10-21T11:40:42]i000: VisualInstaller : Message: Setting result for package: Windows7_MSU_x64, Status=-2145124329
[1F50:1F54][2015-10-21T11:40:42]i319: Applied execute package: Windows7_MSU_x64, result: 0x80240017, restart: None
[1F50:1F54][2015-10-21T11:40:42]e000: Error 0x80240017: Failed to execute MSU package.

...

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Atmel Studio requires .NET 4.6 and Visual Studio Isolated Shell 2015. Since your error message is related to a KB-article it seems reasonable that that KB-article is a prerequisite of either .NET or Isolated Shell. What you could try is to install these separately. Should be fairly easy to find on www.microsoft.com.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

After windows update and reboot, does KB2999226 list as part of the installed updates?

 

http://windows.microsoft.com/en-us/windows/which-windows-updates-installed

 

From the log it looks like the update is still missing from the system.

 

1) Download the Windows6.1-KB2999226-1.0-x64.msu from http://go.microsoft.com/fwlink/?...

2) Install it by double clicking Windows6.1-KB2999226-1.0-x64.msu, if it gives an error then try below steps

3) From command prompt wusa.exe Windows6.1-KB2999226-1.0-x64.msu /extract:C:\ExtractFolder

4) From command prompt DISM.exe /Online /Add-Package /PackagePath:C:\ExtractFolder\Windows6.1-KB2999226-1.0-x64.cab

 

Let me know how it went

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If I try to manually install KB2999226 by double clicking it, I get the message 'The update is not applicable to your computer'. 

 

Using DISM I get the same....

C:\Users\Steven\Downloads> DISM.exe /Online /Add-Package /PackagePath:C:\ExtractFolder\Windows6.1-KB2999226-x64.cab

Deployment Image Servicing and Management tool
Version: 6.1.7600.16385

Image Version: 6.1.7601.18489

Processing 1 of 1 - Adding package Package_for_KB2999226~31bf3856ad364e35~amd64~~6.1.1.5

Error: 0x800f081e

The specified package is not applicable to this image.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

 

The install log show it's already installed, so that might be why it wont install manually. AS7 still tries to install it and can't, so the AS7 install always fails.

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If the package is installed then AS7 should skip the installation of the package. In order to make sure that the package is installed.

 

Can you check the version of api-ms-win-crt-runtime-l1-1-0.dll which is part of the system folder [C:\Windows\SysWOW64] ?

 

If the version of api-ms-win-crt-runtime-l1-1-0.dll is greater than or equal to 10.0.9920.0 then the update is installed and Atmel Studio should skip the installation of the above package.

 

If you find that the version of api-ms-win-crt-runtime-l1-1-0.dll is lesser than 10.0.9920.0. Please get KB2999226 for the OS from https://support.microsoft.com/en... and install it.

 

If the above KB install fails because of compatibility error then use a cab extractor utility and extract the .cab file and copy the files to the System folder and then Install Atmel Studio.

Last Edited: Fri. Oct 23, 2015 - 01:08 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Charla,

 

I don't have a the file  C:\Windows\SysWOW64\api-ms-win-crt-runtime-l1-1-0.dll

 

I little research suggested re-installing Microsoft C++ 2015 Redistributable (x64) - 14.0.23026. I did this but it has the same problem trying to install KB2999226 - 'Error 0x80240017: Failed to execute MSU package.'

 

I've manual extracted the KB2999226 using wusa.exe as above that gave two .cab file, looking inside these there are lots of files (71 in one .cab and over 1000 in the other) I don't understand what to do with them.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

If api-ms-win-crt-runtime-l1-1-0.dll is not available under C:\Windows then the update KB2999226  is not available in your system.

 

Did you try installing the update KB2999226  from https://support.microsoft.com/en.... If you are getting the error related to compatibility?

 

As a workaround I would suggest just:

 

1) Copy api-ms-win-crt-runtime-l1-1-0.dll from the .cab file into C:\Windows\SysWOW64. Check the file version is 10.0.9920.0.

2) Run Command prompt as administrator

3) Run from command prompt as-installer-7.0.594-web.exe SHELLCOMMAND=/NoWeb /NoRefresh /NoRestart. Accept License and proceed with installation.

4) The package Windows6.1-KB2999226-1.0-x64.msu should skip since you have already copied api-ms-win-crt-runtime-l1-1-0.dll (version:10.0.9920.0)

5) Once Isolated Shell installer 2015 GUI appears. Delete api-ms-win-crt-runtime-l1-1-0.dll from C:\Windows\SysWOW64

5) Select the default inputs and install isolated shell 2015.

6) If prompted for restart, please restart the PC

7) Continue with Atmel Studio installation and it should be done.

 

Note: If you get a license expired error when you start Atmel Studio, repair Microsoft Isolated Shell 2015 from Add\Remove programs.

 

I know it is lot of steps for a Friday :-). 

 

HTH,

Charles

 

 

 

 

 

Last Edited: Fri. Oct 23, 2015 - 02:41 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks Charles,

 

Working on this, but KB2999226 will not install manually by any means that's been suggested.  I've also notice that Windows updates has been saying this update has be installed every time I do an update since about July this year. No error, just success but re-installs next update, and if I check now for updates its still in the list of updates despite saying it installed successfully just minutes before, and yesterday and several time before that this week.

 

I've looked for api-ms-win-crt-runtime-l1-1-0.dll in the .CABs form KB2999226 but I can't find it.  I've pulled on of another Windows 7 machine that but it is v10.0.10240.16390. With it the AS7 installer continued past the previous blockage, but then errors when it tries to access the dll (with a missing entry point).

 

I don't understand your step #5 What is the 'Isolated Shell installer 2015 GUI'? I found it in the list of installed programs but it fails to repair - with a error about not being able to find a setup package (vs_isoshell.exe).  And I can find where to download it to re-install. Is it part of another package. I don't have Visual Studio 2015 installed (although I do have VS-2010, VS-2012 Express and VS-2012)

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

api-ms-win-crt-runtime-l1-1-0.dll of v10.0.10240.16390 is fine as it is higher than 10.0.9920.0. 

The dll copy was a hack to bypass the package detection condition in the installer. But we don't want the installer to start with the installation process of other components with that dll present in System folder. [Check the below steps delete it before you start with Isolated Shell installation]

 

1)  Delete api-ms-win-crt-runtime-l1-1-0.dll from C:\Windows\SysWOW64

2)  Since you say that Microsoft Isolated Shell 2015 is part of Add\Remove programs. Try to uninstall it. If uninstall was success go to step 8 else continue with step 3

3) Go to command prompt and run as-installer-7.0.594-web.exe -layout

4) Enter the layout directory in the UI, where the components has to be downloaded

5) Accept the license and proceed.

6) Once extraction to the layout dir is complete.

7) In the lay out directory you will find visual-studio-isolated-shell-14.0.23107.10.exe which is the installer for Microsoft  Isolated Shell 2015. Click on it and uninstall Isolated Shell.

8) Copy api-ms-win-crt-runtime-l1-1-0.dll into C:\Windows\SysWOW64.

9) Run command prompt as administrator and run as-installer-7.0.594-web.exe SHELLCOMMAND=/NoWeb /NoRefresh /NoRestart. Accept License and proceed with installation.

10) Since Microsoft Isolated Shell 2015 is not present in your machine, it will show up the GUI for Microsoft Isolated Shell 2015 installer. [Two GUI's one for Atmel Studio installer and another for Microsoft Shell installer] [Clarification on the point 5 from previous reply]

11) Delete api-ms-win-crt-runtime-l1-1-0.dll from C:\Windows\SysWOW64

12) Now accept license and proceed with Microsoft Isolated Shell 2015 installer. If it prompts for restart do it.

13) Continue with Studio installation.

 

Note: If you get a license expired error when you start Atmel Studio, repair Microsoft Isolated Shell 2015 from Add\Remove programs.

 

Let me know how it goes this time....

 

Attach the installation logs from %temp%\Atmel Studio 7.0.594 if it fails.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

okay, here goes....

 

#1 done (moved to desktop rather than delete)

#2 Uninstall succeeded - going to #8

#8 done (copied back the .dll from the desktop)

#9 started okay but asks 'repair' or 'uninstall' - tried 'repair'....

    fails with same message as before (my first post) trying to install KB2999226

 

On the point about the two installers, I've only seen one (one window - the one attached in my first post)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The uninstall of Microsoft Isolated Shell 2015 did not happen, may be you have uninstalled some other Microsoft Isolated Shell 2012?

 

From what you are saying I think you have Microsoft Isolated Shell 2015 and Atmel Studio in partial state that is the reason you are not seeing the two installers.

 

First thing is to bring the system to a clean slate. I have made modifications to previous steps. 

 

1)  Delete api-ms-win-crt-runtime-l1-1-0.dll from C:\Windows\SysWOW64

2) Go to command prompt and run as-installer-7.0.594-web.exe -layout

3) Enter the layout directory in the UI, where the components has to be downloaded

4) Accept the license and proceed.

5) Once extraction to the layout dir is complete.

6) In the lay out directory you will find visual-studio-isolated-shell-14.0.23107.10.exe which is the installer for Microsoft  Isolated Shell 2015. Click on it and uninstall Isolated Shell. [You should go to Repair\Uninstall screen which means Microsoft Isolated Shell 2015 is present in partial state]

7) Click on as-bootstrapper-external.exe from the layout dir and uninstall Atmel studio.[You should go to Repair\Uninstall screen which means the Atmel Studio 7.0 is present in partial state]

8) Copy api-ms-win-crt-runtime-l1-1-0.dll into C:\Windows\SysWOW64.

9) Run command prompt as administrator from the layout dir and run as-bootstrapper-external.exe SHELLCOMMAND=/NoWeb /NoRefresh /NoRestart. Accept License and proceed with installation.

10) Since Microsoft Isolated Shell 2015 is not present in your machine, it will show up the GUI for Microsoft Isolated Shell 2015 installer. [Two GUI's one for Atmel Studio installer and another for Microsoft Shell installer] [Clarification on the point 5 from previous reply]

11) Delete api-ms-win-crt-runtime-l1-1-0.dll from C:\Windows\SysWOW64

12) Now accept license and proceed with Microsoft Isolated Shell 2015 installer. If it prompts for restart do it.

13) Continue with Studio installation.

 

 

I will be able get more information, if you share the logs from %temp%\Atmel Studio 7.0.594. 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Charles,

Thanks again for you help

 

I confident that it was the 2015 version of the Isolated shell that I uninstalled - it no longer appears in the list of installed programs.  Microsoft Visual Studio 2010 Shell (Isolated) - ENU is still installed. Is that a problem?

 

AS7 was a partial install from the previous attempt(s)

 

#1 done

#2 done

#3 done -> extracted to C:\Users\Steven\Downloads\a7layout

#4 done

#5 completed successfully

#6 Installer opens at the install (choose your installation location) window.  So not installed. Have cancelled this step.

#7 Uninstalled - the uninstalled needed api-ms-win-crt-runtime-l1-1-0.dll so I cancelled and did #8 then repeated #7

#8 see above

#9 done, took the default options (install everything)

#10 The 2015 shell (Isolated) installer now appears

#11 done -> moved to desktop

#12 done - no reboot requested

#13 continues then shows 'The program can't start because api-ms-crt-runtime-l1-1-0.dll is missing from you computer...' dialogue three times and continues after okaying the dialogues,

       after a while shows a forth dialogue with the same error, okayed, and eventuality install completes

 

However, launch produces the error:

System Error

 

If I put  api-ms-win-crt-runtime-l1-1-0.dll back into C:\Windows\SysWOW64 I then get an entry point not found error on launch

Entry Point Not Found

 

Zipped logs are too large to attach (17MB) here is a link: https://www.dropbox.com/s/a53oum...

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Atmel Studio is installed from the logs.

 

Can you try to repair Microsoft Isolated Shell 2015 from control panel or by double clicking on visual-studio-isolated-shell-14.0.23107.10.exe?

 

Hope there are no assemblies which are copied from another machine at present in your System directory.

 

If the repair does not solve the issue then we have to find a distribution for Universal C Runtime for Win7 64 bit usually it is part of Visual C++ Redistributable since it is failing in your machine we have to find a alternative.

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Having tried several more thins in including most of the suggestions - thanks Charles - I concluded its machine (rather than AS7) that has the problem.  All Windows updates are now failing to install. I have five windows updates that have been updating and reporting a success but then install again next day.

 

I need to re-build, or get a new machine.  Then I'll try again