AS6.1 SP2 released today

Go To Last Post
22 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

A tweet from @abcminiuser says 6.1 SP2 is released today and it even includes ARM support for JTAGICE3 - which sounds nice.

Unfortunately I cannot actually find a download link for it yet :-(

I guess it's just a question of patience.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

A tweet from @abcminiuser says 6.1 SP2 is released today

So, we are there already: News on AVRs come on tweets, of Facebook or whatever before they are announced here at 'freaks.

That is just stupid.

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It is there on the atmel site but appears to be labelled incorrctly as the build number is the same as the last update. Could be wrong here with the build thing but when i download it i get downloading "AStudio61sp2.exe"

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

That is just stupid.

Not really, a little bird told me that 72% of people in the US are connected to social networking ;-)

(just to be clear this was not an official Atmel announcement from @Atmel which is Atmel's main presence on Twitter but a personal tweet from Dean Camera who I follow on twitter as @abcminiuser, he may have "jumped the gun").

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hey cliff, do you have a list of the updates ? Only asked as you mentioned ARM support for JTAGICE3

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Installed now and have Version: 6.1.2730 - Service Pack 2. ASF is now 3.11.0

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
Installed now

And still no announcement on AVRfreaks in the AS5/6 forum...

It's there on Atmels Atmel Studio web page, though.

JTAICE3 now supports SAM-D20. Good news!

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

Only asked as you mentioned ARM support for JTAGICE3

My only knowledge of the new version comes from here:

https://twitter.com/abcminiuser/...

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No announcement anywhere other from cliff via deans twitter account. All strange. A while ago i used help/check for updates and was informed there was an update. not now though with this one. Extension manager also indicates no update. What is the correct procedure to update AS6. Shouldnt a user be informed on AS6 startup that a new version is avaliable ?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry guys, I forgot I was obligated to post here first :P. Actually, I assumed marketing wanted to do the post here given that I was told off somewhat for ruining their thunder a while back.

The build number on the site is incorrect, Cliff's screenshot shows the correct build.

Rev: the update mechanism relies on the web team updating a file on the server. It could be that they are still in the process of uploading it, since historically they have been a bit...ah...slow.

My guess is there will be much fanfare about it soon.

- Dean :twisted:

Make Atmel Studio better with my free extensions. Open source and feedback welcome!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What would be nice is some release notes. I can play around a bit and see if I can spot what's changed/fixed but an official list makes the process easier. Presumably it's got all "danv"s recent stuff to do with watching variables?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The release notes are on the Atmel Studio web page.

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'll do the fanfare thing, Dean.

As you've seen from the release notes, the two big things in this release is the SAM D20 support for the JTAGICE3 debugger, and the updated ASF.

There are a few bug fixes as well. Mainly simulator/stimuli related.

ASF is also available for older AS 6.1 versions from Atmel Gallery as a 162 MB download.

We will have the "check for updates" feature report on the new release as soon as the web team fixes the descriptions on the download page. Sending users there now looking for 6.1.2370 will only cause confusion.

Ta-ta-ra-taaaa!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have downloaded and installed the smaller of the install files.

I downloaded the larger "Atmel Studio 6.1 update 2.0 (build 2674) Installer – Full" file twice and it fails to install with a windows installer error on win7.

Is anyone else having the same issue?

regards
Greg

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gregd99 wrote:
I have downloaded and installed the smaller of the install files.

I downloaded the larger "Atmel Studio 6.1 update 2.0 (build 2674) Installer – Full" file twice and it fails to install with a windows installer error on win7.

Is anyone else having the same issue?

Yes, i have the same trouble :(

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, I tried it,the full download, on two windows xp machines and it fails on both.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gregd99 wrote:

Is anyone else having the same issue?

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Dean!

Can you, or anyone else at Atmel, supply MD5 checksums for the different install packages so that it can be resolved if those several cases of 0x80070002 errors reported today is due to corrupt install packages or if there is some other problem?

As of January 15, 2018, Site fix-up work has begun! Now do your part and report any bugs or deficiencies here

No guarantees, but if we don't report problems they won't get much of  a chance to be fixed! Details/discussions at link given just above.

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, I had the same problem. So I downloaded the short-form SP2, which installed painlessly.

SP2 exhibits the same "features". e.g. avr-gcc will NOT work with my Anti-Virus.
e.g. You get project nodes expanding randomly.

One relief is that CodeVision which works fine with SP1 still builds ok with SP2! (and is compatible with my Anti-Virus)

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hashes, as reported by the build system
MD5 full installer: efc61ab6b4e493064e7d4701c461e350
SHA1 full installer: bf899689fa50278716d08ddfe5346020975f4f99
MD5 small installer: 9690bdc7c6e2c98b3647993b686ad4da
SHA1 small installer: 94fa357e3bdf3bb7b0265f6f2197b1a772011fdc

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Seems like the full installer on the server is broken, error 0x80070002. Downloaded yesterday and today again, same result:
MD5: d27443cc7671b4c924fc004164447103
SHA1: 57b24ab38d9df86617aad3590401d00c51ceb2df

The small installer seems fine, I can confirm the MD5/SHA1 from Springvar.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

scp wrote:
Seems like the full installer on the server is broken, error 0x80070002. Downloaded yesterday and today again, same result:
MD5: d27443cc7671b4c924fc004164447103
SHA1: 57b24ab38d9df86617aad3590401d00c51ceb2df

The small installer seems fine, I can confirm the MD5/SHA1 from Springvar.

yes, at me everything is similar.