Disassembler crash

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It's not often I have to delve in to the inner workings of a program to see what stupid obvious mistake i made while writing in C but when I do, I have to keep my fingers crossed as the whether it actually allows me to do so. I'd say that 50% of the time pressing the disassembly button when on a break point causes the IDE to crash, sometimes imediately, sometimes after a few single steps. I have had this problem for a few years now and has been consistant through various iterations of studio 4 my current version is 4.18 build 684. Perseverance is key and eventually after numerous crashes it works and I find I used = instead of == or needed to mark a variable as volatile (nuff said).

Is this a common problem? I have searched for a similar topic but there are no threads returned.

Thanks.

John.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

4.18 build 684.

If you count service packs that one is now 4 versions out of date. Suggest you try again with the recently released 4.19. Also if it is Studio+C does that mean WinAVR? If so which version are you using. If it's not WinAVR20100110 then upgrade to that too.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

j0n90 wrote:
[...]and has been consistant through various iterations of studio 4 my current version is 4.18 build 684.[...]

Have you just been adding new versions again and again? You might try a fresh install. Delete everything related to studio(don't keep the user settings) and Install the latest 4.19. Had some Issues when installing different versions without a fresh install every now and then.