Import AVR Studio 4 Project and Simulator

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have tried use item "Import AVR Studio 4 Project" from menu. My project is designed for AT-Mega168. Everything was OK, but there is no Debug tool. When I try open Menu Project / Options / Debugging - there is no option to select. How can I select SIMULATOR ? In the ToolBar is label "No Debugger". When I click on Start debugging" - open window "Select debug tool" with empty table.
...

Yes I know - I can start new solution for AT-AVR-M168 and by copy / paste "import" all source code. But is there another way?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Solved:
I had to manually insert Simulator path into
Menu: Tools\Options
Item : \Debugger\AVR Debugger
Line : AVR Debugger Path
this text: C:\Program Files\Atmel\AVR Studio 5.0\tools\Simulator

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

AVR Debugger path is meant for specifying the path of the debugger, and not for simulator binaries.In our case it is the path to avrdbg.exe which will be in c:\Program files\Atmel\AVR Studio 5.0\avrdbg\avrdbg.exe usually.

Just out of curiosity,
Are you sure that this workaround helped you fix the problem ?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks,

your answer is good for me. My fault. I think, there is another problem. Sometimes when I am working with AS5, simulator working. Next day, when I start AS5 with the same project, there is no simulator (no item in ComboBox - Selected Debugger). Your answer help me, but important is that sometime when I want turn-off computer, appears Error Window with info that "Process AVRDBG.EXE still running"