What can cause AVR32 debugger to hang?

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi All

I have reported that existing projects can be programmed as BIN files but cause AVR32 programmer/debugger to hang when programmed as ELF file. After several weeks of trying various things, and following limited advice, there still hasn't been any progress so I would like to ask the community whether there are any "hard-core" users who think that they can work out why this is and also find a solution?

Please contact me via private message if you can help - I am willing to pay a reasonable fee for a solution. [An EVK1100 or EVK1105 is needed].

Regards

Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Check that you use an appropriate clock when executing the avr32program tool. The internal is most robust of course, since it does not depend on any hardware. Clock selection is done by passing the -c argument. Type avr32program help program for more details.

Hans-Christian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

what was the error message?

-sma

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi

The messages are discussed here: https://www.avrfreaks.net/index.p...

In fact there are no "error messages" in such since the download "hangs" (either at 0% when trying to program the ELF file using the programmer or 61% when trying to start the debugger) - as can be seen in that thread it is possible to load using Linux so it may be a problem restricted to Windows; note also that this problem is consistent on different Windows PCs; it is also restricted to ELFs from the particular project - other ELFs can load, suggesting that the loaders are expecting something to be found in the ELFs which is not present in the particular project).

As noted in the same thread different clock sources have been tried (internal and external) and the result is the same.

Regards

Mark