Why does AVR32 studio hang when downloading?

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi All

I can load binary files to my board without any difficulties. But I can't get a download to work from the project itself. It hangs forever at 61% until it is aborted - no error messaqe - just "Aborted by user" when stopped.

My feeling is that the ELF is the problem since I can only get binaries to load. It does work for some other projects but never for mine.

Any idea why AVR32 studio is alergic to certain projects - can it be configuration or is it certain ELF content which it can't handle?

Regards

Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi All

As a follow up, but concerning pure programming, I have no problems uploading binary files from the target programming menu - simply setting the address to 0x80000000 is required.

But, I can't upload ELF files although the programmer accepts these. In this case the JTAGICE MkII hangs forever at 0% - I need to remove power to the board to get it to abort.

ELF uploading is not that important but I am wondering whether the programmer just can't do this or whether my elf files (either generated from AVR32 studio or else by a stand-lone make file) are a bit different to that expected by studio so that it fails. In case anyone can help I have attached a ZIP file containing the binary and ELF output from a project for the EVK1105 which displays on the TFT - both Studio V2.5 and V2.6 fail to load the ELF - both can successfully program the BIN (generated from the ELF using obj-copy).

Regards

Mark

Attachment(s):