Programming / debugging tools Xmega

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,
I want to convert an existing development to a xmega device to increase performance. But I only have this MKII programmer (not even a debugger). Does this programmer still works for xmega? What is a good debugging tool for this family?

Greetings,
Dreeke

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There has been an update to the AVRISPmkII to support PDI (needed to program Xmega) but I'm not sure if it's only limited to certain issues of the hardware so you'd need to check.

For debugging you need a $300 JTAGICEmkII or the astronomically expensive AVR One!

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ok, I will investigate the update of the AVRISPmkII. Thanks for the information.

Dreeke

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

I have solved the programmer problem with the purchase of a jtagice mkII CN (the Chinese one). It works perfectly for atmega both for isp and jtag.

Now we are trying to get it running in PDI mode with an ATXmega32A4, unfortunately without success. The connections between the processor and the debugger have no components on their lines (and yes, I have checked that we use the correct pins on the device). Does anyone have experience in using the Xmega with PDI mode? Do we miss some kind of setting we didn't know about? We use the very lastest version of avrstudio.

Greetings,
Dreeke

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The "Original Atmel Jtagice MKII" , is out in 2 hardware revisions. And it's only the latest hw. revision that supports PDI.

So if your chinese version is a "Clone" of the early Atmel Jtagice MKII , you are probably out of luck.

Afaik. both hw. versions support JTAG tovards the XMEGA , it's just the PDI stuff thats missing in the early one.

/Bingo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

I have solved the programmer problem with the purchase of a jtagice mkII CN (the Chinese one). It works perfectly for atmega both for isp and jtag.

Please could you give a link to the device that you purchased. And one day give a report on your experience with Megas and Tinys.

I know that the real JTAG-mkII works well with the xmega. If they have cloned the hardware well, it may be that it receives genuine Atmel software upgades.

There are many Chinese devices advertised on eBay. I am sure that they may work very well. Unfortunately we never hear from the users. So it would be brilliant to know how you have got on.

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

AVRISPMKII From Atmel dist. through Mouser date code 2007-10-30 with the faulty firmware (updated to the latest version)

works fine w/ XMEGA pdi. I just referenced the isp/pdi pinout.