Vista x64 and AVR Studio...again

Go To Last Post
7 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hey! Well I'm just starting to get into AVR's. I use to use PIC's all the time but I realized how much documentation there is for AVR's....and I just had to switch sides. Well I'm in the process of ordering a programmer and what not. But I decided to install WinAVR and AVR studio. But I am running Window's Vista 64bit and after I did some research on and found out that vista 64bit is not completely supported. The specific error I am getting on AVR studio is when I try to compile a program.
I get this error when I attempt to build a project.

../Helloworld.c:28: fatal error: opening dependency file dep/Helloworld.o.d: No such file or directory

I did some research and I found out that I need a folder called .dep and put it somewhere. I made a folder in CMD and have it ready.

Please any sort of information would be extremely appreciated.

David D

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yeah...So I did some more research and I tried the .dll file. But that did not do anything unfortunately. If anyone has had this experience please share.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm wondering if this problem would happen if I tried to assemble some asm code. Can anyone help?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I know zero about Vista64 but Win7_64 works fine except for the USB driver for programming.
Those dependency files should be managed by Studio or possibly an external makefile. If you can't do a $make clean, delete everything except the source and the .aps file and try again. Especially delete the .aws file.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank you. I'll delete everything and try again. Thank you for you're input. What part of NC are you from?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

A bit south of the southern part of heaven :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Really? I think I was there once after I hit my head at a dive competition....but I woke up a few hours later. I don't think I'm going to use my vista 'puter for AVR stuff. I'll use my laptop, I just need to make another partition for XP(I have Xubuntu on it right now)