avrdude 6.4 missing libhidapi-0.dll

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi everyone,

 

I am trying to use my USBasp avr programmer to program the Atinny202.  Unfortunately, Avrdude 6.3 doesn't support it, so

I had to download Avrdude 6.4, which is generating a missing libhidapi-0.dll error.

 

Does anyone know where I can find this .dll?  Or has someone run across this issue?

 

A second question, which pins on the Atinny202 should I be using to program it?

 

By the way, I am using Atmel Studio 7 as the IDE.

 

Regards,

Neil

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Don't cross post!

https://www.avrfreaks.net/forum/...

 

Mod, lock this thread!

 

 My bad, two similar posts about the same thing!  Sorry

and Welcome to AVRFreaks!

 

 

 

FF = PI > S.E.T

 

Last Edited: Fri. Jan 7, 2022 - 09:13 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

which pins on the Atinny202 should I be using to program it?

Looks like it only uses the Reset pin 6 and VCC/GND of course but you need to have a read of the following in the datasheet "30. Unified Program and Debug Interface (UPDI)  "

 as it need 12V it seems.

John Samperi

Ampertronics Pty. Ltd.

https://www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The USBasp only does ISP programming, not UPDI, IIRC!

Take a look at a SNAP programmer/debugger for a low cost tool for UPDI chips.

 

FF = PI > S.E.T

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

neil.prvn wrote:
I had to download Avrdude 6.4, which is generating a missing libhidapi-0.dll error.

 

https://github.com/mariusgreuel/...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Maybe you can find an avrdude build that is statically linked to that lib?

But check inside the compressed file in this link:  https://packages.msys2.org/package/mingw-w64-x86_64-hidapi

 

It seems to use an uncommon compression format, but I think this will open it:  https://mcmilk.de/projects/7-Zip-zstd/

 

But anyways, you have a bigger problem: USBasp doesn't support UPDI, so you can«t program the tiny202 with it.