JTAGICE mkII serial number got reset.

Go To Last Post
13 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My JTAGICE mkII ended up with serial FFFFFFFFFFFF when a firmware update failed.

Is there any way to reenter the correct serial number ?

/Hans

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My JTAGICE mkII is based on ATmega64, and only access to program is "firmware update".

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I don't think its easily recoverable - this tool generation pre-dates the python drivers (maybe time for an upgrade to something like a Snap?)

On the other hand, I think it will still work in the IDE... unless you have two in the same state connected at the same time...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have had lots of problems getting my jtagicemkii to work with AVR STUDIO 6.2.

Latest issue is that atfw -l gives me 2 instances of the programmer.

 

C:\Users\hasse\Documents>atfw -V -t jtagicemkii
atfw 1.13.5003
Atmel Firmware Command Line Interface
Copyright (C) 2015 Atmel Corporation.
Several jtagicemkii is connected
Remove some tools or specify the serial number of the tool to upgrade
Serial: FFFFFFFFFFFF
Serial: FFFFFFFFFFFF

 

When the JTAGICEMKII is removed

 

C:\Users\hasse\Documents>atfw -V -t jtagicemkii
atfw 1.13.5003
Atmel Firmware Command Line Interface
Copyright (C) 2015 Atmel Corporation.
No Tool is found

 

 

What can I do to rectify this ?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The previous was with Studio 7.0.

 

If I install 6.2 I get :

 

C:\Users\hasse\Documents>atfw -l
Connected tools:
jtagicemkii     <n/a>

C:\Users\hasse\Documents>atfw -V -t jtagicemkii
atfw 1.12.4144
Atmel Firmware Command Line Interface
Copyright (C) 2015 Atmel Corporation.
No Tool is found

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you have used the tool with AS7 then it will no longer work with AS6 as it has been "upgraded" and even the drivers are different.

John Samperi

Ampertronics Pty. Ltd.

https://www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

js wrote:

If you have used the tool with AS7 then it will no longer work with AS6 as it has been "upgraded" and even the drivers are different.

 

But it does not work with AS7 either. I want to downgrade the jtagicemkii but as it gives me 2 instances in AS7 it prevents me from doing so.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0


Sorry, you will need to wait for someone that knows more than me then. smiley

 

This is the only thing I could find in the help, I thought there was a link or some button to force upgrade mode but maybe it was for another tool.

 

John Samperi

Ampertronics Pty. Ltd.

https://www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There was a way to force it into boot mode... but its been a decade since I used it, and might leave you with an even brickier brick than you already have.

 

Brick disclaimer: at your risk - you may be stuck in boot mode and I am not even sure its correct.  And I think you will be in boot mode until a successful upgrade...?

- connect VTG and GND to a 5V source

- connect TDO to TDI

- power on

- remove TDO-TDI connection

you should be in boot mode 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Thanks for your effort.

I got hold of a Win7 computer and installed AS 5.1 and was able to load it's firmware to the jtagicemkii.

After this I was also able to download a test program to a 90ATCAN128 and run it in the debugger.

To summarize all works on the Win7 machine.

This proves to me there is no fault in the jtagicemkii.   

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Do keep AS5.1.208, it is friendly to JTAGICE MKII and will suit you well for all traditional ATMEGA and ATTINY- unless you are interested to a new herd of AVRs.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

grohote wrote:

Do keep AS5.1.208, it is friendly to JTAGICE MKII and will suit you well for all traditional ATMEGA and ATTINY- unless you are interested to a new herd of AVRs.

 

Yes I could certainly do with AS5.1 but I really liketo run it on my Win 10 machine.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Jungo might be functional enough on Windows 10 though more likely on Windows 8.1 which has an EOS of 10-Jan'23.

 

AVRISP MKII updated by Studio 7, now can't be seen with Studio 4 | AVR Freaks

What is the Lifecycle Policy for Windows 8.1? | Lifecycle FAQ - Windows | Microsoft Docs

 

"Dare to be naïve." - Buckminster Fuller