tiny104 xplained cannot connect

Go To Last Post
15 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I can't get the xplained 104 to connect. I have tried 3 different xplained boards, 4 different computers (Intel and AMD), 5 different usb leads, 2 different operating systems (win7 and win 10 - with latest updates), in a pc usb port and on a powered hub,  and in both studio7 and studio 6. It (nEDBG) doesn't show up in device manager so I suspect a windows usb driver issue. I also tried an xplained mini and that wouldn't connect either.

 

Is there a spell or incantation I can use to make it work? Or failing that a set of drivers I can download?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0



I can't get the xplained 104 to connect. 

 

You mean when you go to studio 7  selection:  TOOLS/DEVICE PROGRAMMING  you don't see something like

 

note (at least for me), the Xplained328pb shows up  as a composite (it goes away/reappears ) with my xplained removed/installed.  Mine has a serial  port  (maybe they all do?), which also shows up.

 

 

 

When in the dark remember-the future looks brighter than ever.   I look forward to being able to predict the future!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No, just the simulator. And it doesn't appear in the 'Ports' in Device Manager. Btw, I bought these kits when they first came out but I need to use them for a project now.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Have you tried installing the MPLAB X ide?

 

Question for other freaks, does the OP need to download any other support files after loading AS7 to get 104 support?

 

Jim

 

 

FF = PI > S.E.T

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kevinkirk wrote:
It (nEDBG) doesn't show up in device manager so I suspect a windows usb driver issue.
How do I get my Tool to be recognized by Atmel Studio? | Atmel Studio 7

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kevinkirk wrote:
Btw, I bought these kits when they first came out ...
IIRC, some instances of EDBG had updates; EDBG should be an auto-update by atfw.exe though can be done manually.

Automatic Firmware Upgrade Detection | Atmel Studio 7

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Should be in recent Atmel Studio 7 though can check the packs.

http://packs.download.atmel.com/#collapse-Atmel-ATtiny-DFP-pdsc

Device Pack Manager | Atmel Studio 7

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

atfw cannot find them - the mini xplained is the 817 version btw.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Nothing appears in device manager so I can't update the drivers. These modules are fresh out of the box btw so they haven't been damaged.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kevinkirk wrote:
Is there a spell or incantation I can use to make it work?

Have you tried different USB cables, perhaps you are using a charging only USB cable!

 

 

 

FF = PI > S.E.T

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Have you tried different USB cables, perhaps you are using a charging only USB cable!

That is an EXCELLENT point  ...I got some mixed in with other (good) cables & went zany wondering why something  wasn't working....There should be a law that such cable be so marked. 

I found all of those I had and "permanently marked" them with my wire cutters...no more confusion.

When in the dark remember-the future looks brighter than ever.   I look forward to being able to predict the future!

Last Edited: Tue. Oct 27, 2020 - 08:43 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes I tried a number of USB cables. They work fine with the Attiny416nano I've got.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I still think it's a firmware/driver issue can I get old versions?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

avrcandies wrote:

Have you tried different USB cables, perhaps you are using a charging only USB cable!

That is an EXCELLENT point  ...I got some mixed in with other (good) cables & went zany wondering why something  wasn't working....There should be a law that such cable be so marked. 

I found all of those I had and "permanently marked" them with my wire cutters...no more confusion.

 

Wise advice.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"Dare to be naïve." - Buckminster Fuller