Help in using buildroot

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi all,

I have downloaded the latest buildroot from AVR and ran the make atngw100_defconfig and make source.
Finally after running make and waiting 2 hours I ended up with the following error...

configure.ac: 26: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'
automake: configure.ac: required file `./mkinstalldirs' not found
libdaemon/Makefile.am:31: variable `pkg_include_HEADERS' not defined
Makefile.am:29: USE_LYNX does not appear in AM_CONDITIONAL
Makefile.am:24: noinst_DATA defined both conditionally and unconditionally
Makefile.am:20: EXTRA_DIST defined both conditionally and unconditionally
Makefile.am:23: MAINTAINERCLEANFILES defined both conditionally and unconditionally
automake: Makefile.am: required file `./INSTALL' not found
automake: Makefile.am: required file `./NEWS' not found
automake: Makefile.am: required file `./COPYING' not found
automake: Makefile.am: required file `./AUTHORS' not found
automake: Makefile.am: required file `./ChangeLog' not found
configure.ac: 26: required file `./[config.h].in' not found
automake: Makefile.am: warning: automake does not support EXTRA_DIST being defined conditionally
doc/Makefile.am:32: USE_LYNX does not appear in AM_CONDITIONAL
doc/Makefile.am:20: noinst_DATA defined both conditionally and unconditionally
doc/Makefile.am:23: MAINTAINERCLEANFILES defined both conditionally and unconditionally
doc/Makefile.am:24: CLEANFILES defined both conditionally and unconditionally
doc/Makefile.am:21: warning: automake does not support conditional definition of noinst_DATA in EXTRA_DIST
autoreconf: automake failed with exit status: 1

Am I missing some files?

Any help would be most welcome :D

It's being built on an Ubuntu system.

Regards, Mike.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This error occurs because of people having different kinds of autoconf installed.

Could you do a "dpkg -l | grep autoconf"?

Please have both version 2.61 and 2.13 installed. I run Ubuntu Gutsy on my laptop and autoconf works as expected.

Hans-Christian