Firmware file for AVRISP?

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does anyone have the firmware file handy to rewind my avrisp back to a version compatible with the open source flash tools? I cant find a link to the old version of Avrstudio anywhere..

thanks

Richard

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Which open source tools were you interested in? UISP was only compatible with version 1.x firmware, but it is no longer maintained. However, avrdude is still actively maintained, and it's compatible with the latest STK500/AVRISP firmware.

For what it's worth, here's a link to AVR Studio 3.5:
http://www.atmel.com/dyn/product...
Remember that using this firmware will prevent you from being able to work with any AVR models that hadn't been released by December 2002.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am currently using atmega16 so the older firmware shouldn't be a problem for me.

I downloaded AVRDude 5.3.1

I am using the command line:

avrdude rallycomp.hex -cavrisp -pm16

and it responds with:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

The hex file will program if I use AVRStudio. When I search for the messages on google, it comes up with me needing to use an older firmware.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Change that command line to:

avrdude rallycomp.hex -cavrispv2 -pm16

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

thanks, that has fixed my problem