Atmel Studio 7.0 Monitor Lag

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi, hope this is the right place to ask about this.

 

I'm using Atmel Studio 7.0 on a 144Hz monitor and getting frequent and irregular screen lag (to around 30fps or so it seems). It instantly is resolved on closing Atmel Studio. I've tried disabling Virtual Assist. Has anyone run into this before?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

jionbha wrote:
screen lag

not sure what you mean by that ?

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Try to turn off hardware accelerated rendering (Tools/Options)

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1


Deep in the bowels of Visual Studio (and hence Atmel Studio) settings is an option to say "use basic graphics not the fancy DirectX stuff from my video card". That will probably avoid any "odd" behaviour.

 

Can I just say "SNAP!" to Morten while I also add this picture...

 

Last Edited: Tue. May 12, 2020 - 02:35 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank you both! That did the trick.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

... I can't post pictures while out running :)

 

jionbha this does however point to some underlying issue with your graphics driver... 

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)