Help! I've bricked my brand-new AtMega328pb-xplained-mini

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just had to try to adjust the clock using the fuse. Don't know why but I thought we had a xtal on board and I could set it to 16MHz xtal... Well, I tried setting that and in the process I've rendered my unit unprogrammable.

 

I've read a bit about 'high-voltagte' parallel programmers but those seem to only be for DIP packages and I dont want to have to remove the surface-mounted atmega328pb to try this.

 

Please, if anyone knows how to resuscitate the chip I'd be your 'best friend'. Just received the unit on Friday and bricked it by Sunday...

 

I was changing the clock because for some reason I was under the belief that I should be getting serial output on the comport when I used the UART. Upon further digging I think i was misunderstanding something.

 

Hope someone out in AVRFREAK land knows a little something which would save me a bit of grief.

 

Thanks,

Michael

 

Michael Uman
Sr Software Engineer

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

muman613 wrote:
I just had to try to adjust the clock using the fuse.
mega328PB's clock is signal EXT_CLK from the mega32U4.

muman613 wrote:
Well, I tried setting that and in the process I've rendered my unit unprogrammable.
am surprised as mega32U4's mEDGB shouldn't enable bricking.

 


ATmega328PB_Xplained_Mini (schematic) via ATmega328PB Xplained Mini

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

do you have any idea what you actually set the fuses to? value wise?

What programming speed do you actually use?

 

as gchapman says I also find it hard to believe you bricked it. If the fuses can be changed you can brick it, but then you might have also changed other fuses in the process.