receiving/transmitting string through UART

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Heyo community, 

I have a little problem with SPI1. I just cannot figure out how to mycoles configure it corretly to get it working with the spi-functionality provided in spi.h (from ASF).

Is there a step-by-step explanation?

I use it together with a gameduino device and all explanations are for arduino, not AVR32 UC3.

Last Edited: Mon. Jan 13, 2020 - 12:53 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

USART or SPI? Some thing here does not compute?

jim

 

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well, SOME UARTs can function as an SPI port. That said, as you observe, things do not add up.

 

Jim

Jim Wagner Oregon Research Electronics, Consulting Div. Tangent, OR, USA http://www.orelectronics.net

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Also, what micron are you using?

Jim

I would rather attempt something great and fail, than attempt nothing and succeed - Fortune Cookie

 

"The critical shortage here is not stuff, but time." - Johan Ekdahl

 

"Step N is required before you can do step N+1!" - ka7ehk

 

"If you want a career with a known path - become an undertaker. Dead people don't sue!" - Kartman

"Why is there a "Highway to Hell" and only a "Stairway to Heaven"? A prediction of the expected traffic load?"  - Lee "theusch"

 

Speak sweetly. It makes your words easier to digest when at a later date you have to eat them ;-)  - Source Unknown

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB, RSLogix user