FreeRtos for the ATXMEGA128A1

Go To Last Post
56 posts / 0 new

Pages

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I am already referring to both of these, as I am using the IAR compiler and latest version of FreeRTOS. As said in  "yuriykulikov/FreeRTOS-on-XMEGA · GitHub", I only have to change the portable folder file.

 

After doing that, I am able to successfully compile the code. But while debugging(running), it crashes( i.e. restart again to main) from the vPortStart(just after portRESTORE_CONTEXT).

 

Can you help me out?I dont know the root cause why it is happening.(tell me if anythings i you required)

 

Thanks.

Regards,
Shiv Pratap Singh

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

freakShiv wrote:
Can you help me out?
Likely no as I have zero experience with FreeRTOS.

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote:

freakShiv wrote:
Can you help me out?
Likely no as I have zero experience with FreeRTOS.

 

Me neither.

"Experience is what enables you to recognise a mistake the second time you make it."

"Good judgement comes from experience.  Experience comes from bad judgement."

"Wisdom is always wont to arrive late, and to be a little approximate on first possession."

"When you hear hoofbeats, think horses, not unicorns."

"Fast.  Cheap.  Good.  Pick two."

"We see a lot of arses on handlebars around here." - [J Ekdahl]

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for support.

 

I think I have found the reason(still in progress), it was because of the assembler file(which is required in IAR compiler not in other compilers) for FreeRTOS.

 

As it is working fine for the Atmel Studio ( i.e. same portable file).But let me check.

 

 

 

Regards,
Shiv Pratap Singh

Pages