Interfacing ESP8266 with atmega8

Go To Last Post
9 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am using ESP8266 i have configured my ESP i am sending the following AT commands from serial port of atmega8

<code>AT+CWMODE=3   // station + AP mode
AT+CIPMUX=0
AT+CIPMODE=0
AT+CWJAP="SSID","PASS"
AT+CIPSTART="TCP","192.168.1.x"    //where 192.168.1.x is the ip currently assigned to my mobile phone 

</code>

the last command gives error. 
Both ESP and my mobile are on same network with same subnet ip
I have installed Wifi terminal on my mobile but when i input id of ESP it says conenction refused.
I was able to develop communication whhen i had used ESP as AP and a wifi extender to extend the range but now I am unable to develop any communication between the two devices(ESP and my mobile) with router bieng the AP

Last Edited: Wed. Apr 10, 2019 - 08:51 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

SufyanRaza26 wrote:
the last command gives error. 

https://www.cfd-online.com/Forum...

 

Welcome to AVRFreaks!

 

Jim

 

Click Link: Get Free Stock: Retire early! PM for strategy

share.robinhood.com/jamesc3274
get $5 free gold/silver https://www.onegold.com/join/713...

 

 

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I meant literally it gives "ERROR" All the other AT commands end up with "ok" but this  last command only returns "ERROR" followed by "CLOSED" 

Also i have checked from my laptop command line the ping command to both the ip (mobile and ESP module) returns positive results.   

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There are forums dedicated to the ESP8266 (esp8266.com???) that are better placed to answer your query.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Nothing to do with Studio, moving to AVR forum.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly