AVRISP mkII upgrade failed, how to restore?

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

just tried to use an AVRISP mkII with the new Atmel Studio 7.0. It showed a prompt to upgrade the firmware from 1.17 to 1.18, where I clicked on "upgrade". But it failed with: "AVRISP MkII firmware upgrade failed. Toggle power on tool and retry upgrade". As usual for such errors, toggling power and retrying to upgrade didn't work. Tried the following instruction: http://www.atmel.com/webdoc/avri...

But I failed at step 6. I used the archive from Olimex(https://www.olimex.com/Products/...). It just throws the following error: "GenericError thrown during firmware upgrade. Could not open E:\TMP\13f3-8903-02ca-f494\avrtools_fw.xml".

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I used the archive from Olimex

So what does the AVRISP mkII upgrade have to do with it? Is it an Atmel AVRISP mkII or something else?

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, it's the Atmel AVRISP mkII. Found out that the Firmware of the Olimex board is totally different from the Atmel board, so that was the reason for the strange error. I've found the right firmware at the following directory: \Atmel\Studio\7.0\tools\AVRISPmkII

Now it throws another error when trying to upgrade the AVRISP: "Failed to connect to the specified tool. Make sure your tool is connected and you are using the correct serial number". But previous to that, it shows that it has "Found avrispmkii:000200(...)".

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

when i connect atmega128A to Atmel studio I get this problem that " AVRISP mkII firmware upgrade failed toggle the power and retry to upgrade how I can fix below is the attachment of error. thanks in advance