AS7 - Trouble installing extensions; faulty dependency checking?

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I downloaded the Wireless Composer 7.0 extension from https://gallery.microchip.com/pa...

 

It fails to install:

 

 

'View Install Log gives:

15/05/2018 15:24:35 - Microsoft VSIX Installer
15/05/2018 15:24:35 - -------------------------------------------
15/05/2018 15:24:36 - Initializing Install...
15/05/2018 15:24:36 - Extension Details...
15/05/2018 15:24:36 - 	Identifier      : 96EB07D7-6144-450B-A7CF-4D881B611610
15/05/2018 15:24:36 - 	Name            : Wireless Composer 7.0
15/05/2018 15:24:36 - 	Author          : Atmel
15/05/2018 15:24:36 - 	Version         : 7.0.130
15/05/2018 15:24:36 - 	Description     : Provides the Wireless Performance Analyzer and IEEE 802.15.4 MAC Project Wizard. Wireless Performance Analyzer is used to demonstrate various features and capabilities of Atmel IEEE 802.15.4 Transceivers and BLE Transceivers. IEEE 802.15.4 MAC Project Wizard provides user interface to create firmware projects based on AVR2025 MAC stack using Atmel microcontrollers and IEEE 802.15.4 transceivers.

Prerequisites:
-	Atmel Studio 7.0.934 or later
-	Atmel Software Framework v3.31.0.435 or later
-	Performance analyzer Firmware available in the package "Wireless Performance Analyzer Firmware" (download from Atmel Gallery)
-	Performance analyzer Firmware Source code available in ASF v3.31.0.435 or later (download from Atmel Gallery)

15/05/2018 15:24:36 - 	Locale          : en-US
15/05/2018 15:24:36 - 	MoreInfoURL     : 
15/05/2018 15:24:36 - 	InstalledByMSI  : False
15/05/2018 15:24:36 - 	SupportedFrameworkVersionRange : [4.0,4.6]
15/05/2018 15:24:36 - 
15/05/2018 15:24:36 - 	Supported Products : 
15/05/2018 15:24:36 - 		AtmelStudio
15/05/2018 15:24:36 - 			Version : [7.0]
15/05/2018 15:24:36 - 
15/05/2018 15:24:36 - 	References      : 
15/05/2018 15:24:36 - 
15/05/2018 15:24:36 - Searching for applicable products...
15/05/2018 15:24:37 - Found installed product - Microsoft Visual Studio Express 2013 for Windows Desktop
15/05/2018 15:24:37 - Found installed product - Global Location
15/05/2018 15:24:37 - Found installed product - AtmelStudio
15/05/2018 15:24:37 - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
   at VSIXInstaller.App.InitializeInstall()
   at System.Threading.Tasks.Task.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()

 

I have Atmel Studio 7.0.1417 with ASF 3.34.1 installed - which, surely, meets those stated Prerequisites ?

 

So why won't it install?

 

angry

 

If I try to do this from 'Extensions & Updates' within AS, it says I need to download & install Extension Manager.

 

So I do that, and get a similar "this is not installable on any currently installed products" error.

 

angry

 

I'm now downloading the latest AS (7.0.1645) - but why won't these install when I meet their stated prerequisites??

 

 

This topic has a solution.

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
Last Edited: Tue. May 15, 2018 - 03:24 PM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

awneil wrote:
I'm now downloading the latest AS (7.0.1645) - ...
fyi 7.0.1652

Problem with Extensions and Updates

by freezyundead

https://www.avrfreaks.net/forum/problem-extensions-and-updates

...

https://www.avrfreaks.net/forum/problem-extensions-and-updates#comment-2409981

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

7.0.1645 is still the latest available on  http://www.microchip.com/avr-support/atmel-studio-7

 

 

and, sure enough, it still has the same problem!!

 

angry

 

 

Aaaaaaaaaagh!! that's dated 2 March - and they still haven't fixed it!!

 

angry

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Thanks for that!

 

It wasn't quite the solution - but it did lead to the solution.

 

See comment there

 

smiley

 

Top Tips:

  1. How to properly post source code - see: https://www.avrfreaks.net/comment... - also how to properly include images/pictures
  2. "Garbage" characters on a serial terminal are (almost?) invariably due to wrong baud rate - see: https://learn.sparkfun.com/tutorials/serial-communication
  3. Wrong baud rate is usually due to not running at the speed you thought; check by blinking a LED to see if you get the speed you expected
  4. Difference between a crystal, and a crystal oscillatorhttps://www.avrfreaks.net/comment...
  5. When your question is resolved, mark the solution: https://www.avrfreaks.net/comment...
  6. Beginner's "Getting Started" tips: https://www.avrfreaks.net/comment...