AVR Dragon and AT90XXXXXX

Go To Last Post
22 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I did not find that dragon does support AT90CAN and/or other AT90 devices. Please confirm this or tell where can I find that this is wrong.
Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The help in Studio 4.13.528 for the Dragon lists

AT90CAN32
AT90CAN64
AT90CAN128
AT90PWM2
AT90PWM2B
AT90PWM3
AT90PWM3B
AT90USB646
AT90USB647
AT90USB1286
AT90USB1287

Perhaps you don't have 4.13.528 from www.atmel.no/beta_ware/ ??

Naturally it doesn't list any of the old AT90S devices on this page for obvious reasons:

http://www.atmel.com/dyn/product...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I don't use any beta software - that is our company policy.
http://www.atmel.com/dyn/products/tools_card.asp?tool_id=3891 as well as http://www.digikey.com/scripts/DkSearch/dksus.dll?Criteria?Ref=119039&Site=US&Cat=34145289
has only Atmega128, 168, 32, 48, 8, 88, ATtiny13, 2313, 24, 25, 45, 85

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Well that's OK because build 528 is NOT a beta version - it's the release of 4.13 - you'll see the words "(Release)" on that page I linked to - suggest you keep an eye on the AVR Studio 4 forum in future for other release announcements!

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you talk to your Dragon through avrdude, then the device support includes the entire corpus of ISP-enabled AVR microcontrollers.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Anyway, it ought to be no problem to program the obsolete
AT90xxx devices through ISP or HV programming. Obviously,
emulation wouldn't be available for them anyway.

Jörg Wunsch

Please don't send me PMs, use email if you want to approach me personally.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

...Obviously, emulation wouldn't be available for them anyway.

Hence I only mentioned using avrdude, rather than avarice.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

I did not find that dragon does support AT90CAN and/or other AT90 devices. Please confirm this or tell where can I find that this is wrong.

Quote:

I don't use any beta software - that is our company policy.

LOL LOL LOL ROFL Geez, I really gotta bite my tongue to stop another round of brberie baiting. Do you wanna use the Dragon or not? Do you wanna use it on your AT90CAN or not? Those are >>your<< choices; if you/your company >>choose<< not to do that it is up to >>you<<. No amount of whining here is going to change the release state of AVRStudio.

Better not use most AVRs; the datasheets are marked "PRELIMINARY".

Quote:

“It is often easier to ask for forgiveness than to ask for permission.”

-- Rear Admiral Grace Murray Hopper

Lee

You can put lipstick on a pig, but it is still a pig.

I've never met a pig I didn't like, as long as you have some salt and pepper.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

theusch wrote:
Quote:

I really gotta bite my tongue...

Lee

My congratulations! That is first reasonable post from you I ever read!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yeah, but you won't take the good advice in the rest of the post. I have never seen any other posters on this site that feels that the world revolves around them except you.

Lee

You can put lipstick on a pig, but it is still a pig.

I've never met a pig I didn't like, as long as you have some salt and pepper.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

clawson wrote:
The help in Studio 4.13.528 for the Dragon lists

AT90CAN32
AT90CAN64
AT90CAN128
AT90PWM2
AT90PWM2B
AT90PWM3
AT90PWM3B
AT90USB646
AT90USB647
AT90USB1286
AT90USB1287

Perhaps you don't have 4.13.528 from www.atmel.no/beta_ware/ ??

Naturally it doesn't list any of the old AT90S devices on this page for obvious reasons:

http://www.atmel.com/dyn/product...

Well, I have installed 4.13.528 and bought Dragon...
Build 528 was crashing with JTAG-mkII and the only thing I was able to do is to uninstall it and install 498 back. It works without issues. Just to exclude unnecessary questions: I have un-installed and re-installed 528 several times without any luck...
Then (on another computer) I tried Dragon and 528. It does NOT support Dragon for AT90XXXX as a debug platform. Obviously I'm not happy at all
:(

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hum...
AT90CAN32 is listed for me in 4.13.528 as supported by the Dragon for debugging via JTAG.
AT90PWM2/3 are listed for me in 4.13.528 as supported by the the Dragon for debugging via debugWire.

All of the other new AT90*** devices have a Flash size larger than 32 kB. As such, we've been led to believe (by discussions with Atmel representatives) that they will never be able to operate in On-Chip Debug mode with the Dragon.

Last Edited: Wed. Mar 7, 2007 - 05:35 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I haven't the first idea what you are talking about. Are you saying your Select platform/device for debugging dialog does not show the following in your copy of 4.13.528? It does in mine:

[By the way you keep mentioning AT90XXXX without saying what the XXXX actually is - as long as it doesn't start with the letter S (or have a flash capacity greater then 32KiB) you should be OK but clearly Atmel aren't going to support the ancient old mature products in a modern, new device like the Dragon and they aren't going to undercut sales of their JTAGICEmkII to customers using the big devices]

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have AT90CAN 64/128 :(

Attachment(s): 

Last Edited: Wed. Mar 7, 2007 - 05:54 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Ouch.

I think there's no debugging option except for the JTAGICE mkII for those units...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lfmorrison wrote:
Ouch.

I think there's no debugging option except for the JTAGICE mkII for those units...


That means $299+S&H

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

brberie wrote:
That means $299+S&H

Indeed it does - complain to the Atmel marketing department if this is a problem. They've clearly made a commercial decision to make an artifical split between the Dragon and the JTAGICEmkII based on device flash size with the boundary at 32K

Just an idea though - can't you temporarily use an AT90CAN32 for development and work on the code in a modular fashion - do any debugging with the Dragon in that smaller device then, when it's proven working, integrate it into the main build for the 64/128 devices (which the Dragon *should* be able to program at least even though you won't be able to see what's going on "inside")

Cliff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

http://www.olimex.com/dev/
Does this support AT90CAN?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Nope, all the non Atmel JTAG products are clones of the original JTAGICE and, as listed
in Studio help, the only devices this supports are:

ATmega16(L), ATmega162(L), ATmega169(L or V), ATmega32(L), ATmega323(L), ATmega64(L), ATmega128(L).

Like I say, Atmel marketing have you by the short and curlies on this one!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:
That means $299+S&H
How much did your pc cost? How about the rest of the lab/workshop you are in?
Just be thankful that you don't have to spend $20,000.00+ like it did a few years ago for a development system :) or even a few thousand $ for an ICE50. $300.00 is nothing for a company. My company does not need a JTAG MK2 yet as I can do everything with the Dragon or even the JTAG MK1. I would not bat an eyeleid if I had to spend that money for a project that needed it.
(Now Atmel will have to send me a free one for going into bat for them... :lol: )

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

js wrote:

(Now Atmel will have to send me a free one for going into bat for them... :lol: )

Let us know when you'll get one! :lol:

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

> http://www.olimex.com/dev/
> Does this support AT90CAN?

I believe it will support the AT90CAN128 but none of the more
recent ones.

Jörg Wunsch

Please don't send me PMs, use email if you want to approach me personally.