Studio 7.0.1645 can no longer program fuses with SAM-ICE?

Go To Last Post
3 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Is there any way to install an older version of Studio?  7.0.1645 seems to have broken programming the fuses on a samd21 J18A using SAM-ICE - the one laptop I have with 7.0.1417 still works.

 

This is kind of a big deal, as I'm trying to set up a machine to program boards during manufacturing, and the tools have stopped working on me!

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes you can install an older version.  But running two different versions at the same time on the same machine is a problem.  So, first uninstall .1645.  Then download the full install .exe for an earlier version such as .1417 or .1188 and install.  Each version of course has it's own issues.

Here's a link to the older versions:  http://www.microchip.com/avr-sup....

Due to our production quality system we're required to keep a copy of the install file for the development tools in our configuration management vault.  It's a really good idea to keep local copies like this since you can't always get a version older than one or two revisions prior to the most recent one.  Obviously it depends upon the vendor.

Edit:  looks like Microchip hasn't posted 7.0.1417 to the archive site listed above.  Give the support line a call and they'll help you out.  Looks like this is a case where my company's quality system policies would have helped out :) 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

... until the archive page is updated: http://studio.download.atmel.com...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

 

The postings on this site are my own and do not represent Microchip’s positions, strategies, or opinions.