Using flip with XMega

Go To Last Post
11 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does someone is using flip with XMega devices?

I attempted to use flip on ATXMega64A3U, but Windows 7 keeps complaining that the driver cannot be found.

Installing the drivers found in the flip directory fails. Googling around I found other persons who can't run flip on W7, you can also download some "special" drivers that should solve the problem. But no luck with them, either :-(

So, if someone was able to run flip, please give me some hints.

Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I use Flip 3.4.4 on Win7/64 with ATXmega32A4U without any Problems.

Regards

Rainer

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for your answer, Rainer.
So you were able to install the driver for Flip - and this is at the moment my problem.
Did you use the driver from Atmel or something different?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I only used the flip program from Atmel which includes the driver.
Yesterday i installed version 3.4.5 because the older version 3.4.4 doesn't support ATXMega128A4U.
So for me it works as it should.

Rainer

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Problem solved.
I was overzealous in telling to Windows the directory the driver was.
Instead of C:\Program Files\Atmel\Flip 3.4.5\usb\x86 I simply tried C:\Program Files\Atmel\Flip 3.4.5 and the driver got installed.
Now I have to study a bit the code that comes with ASF and see how to customise the bootloader.

Thank you for your support. Knowing that you were able to run the driver, I didn't give up too soon :-)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Having a similar problem, though when I download FLIP 3.4.7 from Atmel, it looks as though i'm missing libusb0.dll.  Should this be included in the download?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You're probably better off starting a new topic than digging up a 3 year old thread.

The largest known prime number: 282589933-1

In my humble opinion, I'm always right. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Depends on how the forum works, but I'll start a fresh one, I suppose.  Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi

i can not connect xmega64a3u to my pc (windows 7/64bit)

my flip version is 3.47 .

please help me !

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

fyi, the FLIP protocol was added to AVRDUDE.

http://savannah.nongnu.org/forum/forum.php?forum_id=8461

part of the call :

sudo avrdude -c flip2 -p <XMEGA> -U application:w:...

sudo avrdude -c flip2 -p <XMEGA> -U eep:w:...

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does anything from the following help?  (I wasn't aware of the Windows 10 and FLIP problem)

http://atmel.force.com/support?q=FLIP

to

http://atmel.force.com/support/articles/en_US/FAQ/Programming-AVR-XMEGA-devices-using-USB-peripheral

"Dare to be naïve." - Buckminster Fuller

Last Edited: Fri. Feb 26, 2016 - 03:00 AM