building for linux

Go To Last Post
6 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,
I'm trying to install the gnu tool chain under linux. Eveything worked fine, till I tried to make gdb. I got the error message from make, that I don't have a termcap library. Any suggestions what to do? I googled already for termcap+gdb, but since I'm new to linux I didn't understand to much of what Ifound.

Thanks for help.

Florian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What Linux distribution do you use? And have you checked if there are prebuilt AVR packages for your distribution? For instance, I use Debian sarge, and all I need to to is:

apt-get install gdb-avr

The message about termcap is strange, since avr-gdb on my system doesn't use termcap, only libncurses5 and libreadline5.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I use suse9.0 and I cannot find any prebuild packages. Do you know where to get the termcap library. Googling just resulted in documentation about termcap, but I couldn't find it for download!

Thanks!

Florian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

:oops: Thank you very much!

Florian

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Actually that link is wrong as it's the 64 bit version. Try:

http://rpm.pbone.net/index.php3

Cliff