Atmel Studio 6.2 GNU ARM Toolchain error

Go To Last Post
2 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just upgraded from Atmel Studio 6.1 to 6.2.1563 SP2. I did this by completely uninstalling 6.1 along with all toolchains and installing 6.2. Now when I try to load up a project I get an error message: "error  : The toolchain com.Atmel.ARMGCC.C is not installed to Atmel Studio. Please goto Tools -> Extension Manager and install it properly."

 

I can see in the extension manager that the ARM GNU Toolchain is installed (ver. 4.8.4.1443). When I tried to install an earlier standalone version of the ARM GNU toolchain I got an error message saying a newer version is already installed.

 

I have tried completely uninstalling including "Microsoft Visual Studio 2010 Shell (Isolated) - ENU" and then doing a clean install. I didn't get any error messages during installation. My install log is attached. I'm not sure what else to try. Anyone else have this issue?

 

OS: Windows 7 Pro x64

 

 

Attachment(s): 

This topic has a solution.
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I finally got all of my toolchains back. This fix worked for me: https://www.avrfreaks.net/forum/p...

 

  1. Download and install Atmel Studio 6.1 (Build 2674)
  2. Install all available extension and toolchain updates.
  3. Download and install Atmel Studio 6.2 (Build 1548)
  4. During the installation when prompted whether you would like to share the 6.1 toolchains with 6.2 select "Yes".
  5. Start up AS6.2 and go to Tools -> Options -> Toolchain and confirm all toolchains appear in the drop-down menu.
  6. Reward yourself with a delicious growler of Boneyard Hop Venom.