AS6.1 - Task list is empty after opening project.

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi.

I'm using Atmel Studio 6.1.2730.

I have multi file project with few tasks on task list (TODO, etc). After opening project, task list is empty.

What should i do to see my tasks from all files from project?

Regards!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The task list is populated by a background thread when a solution is loaded. This means that it may take 'some time' until all tasks has been found and added.

You are saying that you have them on the task list, but not on the task list when you open a project? Do they then appear?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thx, for replay.

When i'm editing my code and add task by writing:

//TODO: something

task is add to Task list immediately. If I do it in different files, all tasks are on Task list.

After save solution, close and open it again, task list is empty. I was waiting, but Task list was always empty. For example project (not finished): dd_syntezator.zip

But when i do some edition in file for example dd_adsr.c just adding one space or something else, Task list is refreshed immediately and there are task but only from this file dd_adsr.c.

To see tasks from other files from solution i must do the same in each file for example dd_syntezator.c, dd_adsr.h, etc.

I just prepare simple new solution, and it works fine - tasks are on the Task list after opening solution: my_project.zip

I'm surprised :)

I have no idea what am i doing wrong.

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

A bit late coming to this thread, but I'm seeing the same thing, and you're not doing anything wrong. AS6.1 is hosing this up somehow. I've used many versions of Visual Studio, and I use the Task list heavily in most projects. The time to load all tasks for even a gigantic solution is just a few seconds. I've never seen this behavior before.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Quote:

AS6.1 is hosing this up somehow.

Any better in 6.2?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Don't think there have been any change in this parser for 6.2, but it might be better...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hello.
i have as6.1
why this version dont allow me to edit and save a header or library file?
i edit a header but as6.1 dont allow me to save file in same dir and same name

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

the error is:

Attachment(s):