assembler 2 bug

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I wrote some code that crashed the assembler
click build - a little box comes up saying assember crashed
and a log is being created - although I never found the log.

I finally traced it to a typo (actually several of them from cut&paste)
ld r1, Z+3
which is supposed to be
ldd r1, Z+3

this is an error - but it crashed the assembler!

using studio 4.10 latest version (not the beta version)
it crashed with or without -2 option

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Report this to Atmel! This is the kind of thing they need to know about.

-Curiosity may have killed the cat
-But that's why they have nine lives

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This problem has already been found and fixed. You have a misconception about beta. So far, all Assembler 2 versions are beta. In AVR Studio 4.10 menus, under "file", "AVR Assembler", the setup dialog box clearly stated "use AVR Assembler 2.0 Beta". If you do not want to use the beta assembler, then un-check this box to use the older/original non-beta version 1.something.

The problem you found was fixed in a patch (Assembler 2 beta 6):
https://www.avrfreaks.net/phpBB2/...

You can also get Assembler 2 beta 7 from the ATMEL beta software link (AVR Studio 4.10 Update 1, build 359):
http://www.atmel.no/beta_ware/

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sceadwian wrote:
Report this to Atmel! This is the kind of thing they need to know about.

Mike B wrote:
This problem has already been found and fixed. You have a misconception about beta

Mike,

While you are right, I'm with Sceadwian on this one. We need to be told about bugs. I'll rather have the occasional duplicate than bugs that go unreported because people feel they haven't the time to do a full research before reporting a problem.

The important thing for me is that the bug report is concisely formulated, refers to the exact product version used, and preferably has a code example. As this one was.

While at it, I want to thank everybody who provide AVRASM2 feedback on this forum or otherwise. Your help is appreciated.

Roland Kruse
Atmel AVR Tools

Please don't report bugs in private forum messages.
--
Roland Kruse
Atmel AVR Tools