Forum Menu




 


Log in Problems?
New User? Sign Up!
AVR Freaks Forum Index

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
asifavr
PostPosted: Feb 29, 2012 - 10:41 AM
Newbie


Joined: Feb 29, 2012
Posts: 5


Hello there I am trying to burn the hex file using ATMEL JTAGICE mkII ,but I get this message-"FAILED TO IDENTIFY TARGET,WOULD YOU LIKE TO RETRY WITH EXTERNAL RESET ENABLED ?",Please look at the screen shot attached to this post.I have tried to disconnect the Jtag ice device and then tried to connect and burn the .hex but the same problem persists.

I had no issues as such when I was working with these softwares but off late this has become really annoying

Following are the list of the softwares with versions installed on my system running Windows 7(64 bit)

1)AVR JUNGO USB - 10.2
2)AVR TOOLCHAIN - 3.3.0.110
3)AVR STUDIO - 4.18.716
4)AVT TOOLS - 1.00.0000
5)WinAVR - 20090313

Can someone help me to troubleshoot this issue,I have tried uninstalling the softwares and reinstalling them again.
Thanks and regards
 
 View user's profile Send private message  
Reply with quote Back to top
clawson
PostPosted: Feb 29, 2012 - 10:53 AM
10k+ Postman


Joined: Jul 18, 2005
Posts: 69334
Location: (using avr-gcc in) Finchingfield, Essex, England

Silly question but it is a JTAG rather than an ISP link you have made to the 2560? The picture says "JTAG"

_________________
 
 View user's profile Send private message  
Reply with quote Back to top
asifavr
PostPosted: Feb 29, 2012 - 11:27 AM
Newbie


Joined: Feb 29, 2012
Posts: 5


Nothing silly I guess ...its detecting ...please check the screenshot for confirmation

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
asifavr
PostPosted: Feb 29, 2012 - 11:28 AM
Newbie


Joined: Feb 29, 2012
Posts: 5


What more proof I can give that I am trying to use a JTAGICE mkII and I have used it several times before encountering this issue??thanks
 
 View user's profile Send private message  
Reply with quote Back to top
clawson
PostPosted: Feb 29, 2012 - 11:44 AM
10k+ Postman


Joined: Jul 18, 2005
Posts: 69334
Location: (using avr-gcc in) Finchingfield, Essex, England

Then the fact the Studio can clearly talk to the ICE and that this exact same setup (with JTAG rather than ISP selected) worked before surely says "wiring problem".

Note that the JTAGICEmkII ribbon cables have been known to break and I think Atmel have spares on their site:

EDIT: yes: http://store.atmel.com/PartDetail.aspx? ... 7;c:100119

_________________
 
 View user's profile Send private message  
Reply with quote Back to top
asifavr
PostPosted: Feb 29, 2012 - 11:47 AM
Newbie


Joined: Feb 29, 2012
Posts: 5


OK 10k+Superfreak will check this and get back ...but I am quite sure about the cables nothing seems to be wrong..but will check thoroughly ..thanks
 
 View user's profile Send private message  
Reply with quote Back to top
js
PostPosted: Feb 29, 2012 - 09:50 PM
10k+ Postman


Joined: Mar 28, 2001
Posts: 22228
Location: Sydney, Australia (Gum trees, Koalas and Kangaroos, No Edelweiss)

Quote:
-"FAILED TO IDENTIFY TARGET,WOULD YOU LIKE TO RETRY WITH EXTERNAL RESET ENABLED ?",
That USUALLY happens if the code disables JTAG when running. I hope your JTAG header has the reset pin wired up to it.

Edit you also seem to have a strange mix of software including a very old version of winAvr.

_________________
John Samperi
Ampertronics Pty. Ltd.
www.ampertronics.com.au
* Electronic Design * Custom Products * Contract Assembly
 
 View user's profile Send private message Visit poster's website 
Reply with quote Back to top
asifavr
PostPosted: Mar 01, 2012 - 01:02 PM
Newbie


Joined: Feb 29, 2012
Posts: 5


Hello John thanks for giving some more troubleshooting hints ...well I forgot about another message thats been displayed before the AVR studio throws the error "FAILED TO IDENTIFY TARGET,WOULD YOU LIKE TO RETRY WITH EXTERNAL RESET ENABLED ?"

Attached to this post is the error message regarding the minimum voltage required for detection.I tried connecting several times and I got the target detected just once out of several tries ..

The following list is the softwares I have installed
1)AVR JUNGO USB - 10.1
2)AVR TOOLS - 1.00.0000
3)AVR STUDIO - 4.18.716
4)WinAVR - 20090313

Yes the softwares are old but I can't help it.Its only because of these softwares I am able to build a zero-error/warning hex file and finally burn it on the hardware.

Any other troubleshooting steps so that the target can be easily identified.

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
js
PostPosted: Mar 01, 2012 - 10:08 PM
10k+ Postman


Joined: Mar 28, 2001
Posts: 22228
Location: Sydney, Australia (Gum trees, Koalas and Kangaroos, No Edelweiss)

And what is your VCC? If it drops with the JTAG plugged in then you have probably a short circuit in the I/O protection chip which sits behind the cable header inside the JTAG.

_________________
John Samperi
Ampertronics Pty. Ltd.
www.ampertronics.com.au
* Electronic Design * Custom Products * Contract Assembly
 
 View user's profile Send private message Visit poster's website 
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT + 1 Hour
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2006 The PNphpBB Group
Credits