USB, batchisp "no device present"

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi...

I'm currently having problems with programming a UC3B0256 via USB from my Ubuntu-box (Xubuntu 7.10)..

building projects etc. works fine, but when doing

make isp program run

I end up with

=====================================================
= start batchisp
=====================================================
Running batchisp 1.2.0 on Tue Nov 20 21:46:24 2007



AT32UC3B0256 - USB - USB/DFU


Device selection....................... PASS 
Hardware selection..................... PASS 
Opening port........................... AtLibUsbDfu: 3EB 2FF6 no device present.
FAIL    Could not open USB device.
ISP done.

=====================================================
= end batchisp
=====================================================

according to dmesg and lsusb, it's definately there, and has the right vendor:product number:

[18249.952000] usb 2-1: new full speed USB device using uhci_hcd and address 5
[18250.132000] usb 2-1: configuration #1 chosen from 1 choice
[···]
Bus 002 Device 005: ID 03eb:2ff6 Atmel Corp. 

running as root doesn't help...

Taking the same steps on windows does work...

Any ideas will be appreciated :)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Should probably be in the software tools forum, this is more for running linux _on_ an avr32 but not to worry :)

I've only ever seen this fail if you don't have permissions, in which case running as root should do the trick. What does "avr32program -l" have to say, both as root and non-root users?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ah... missed that point of it being linux ON avr :) (we're using FreeRTOS)

avr32program -l says absolutely nothing... I'm guessing I did something wrong on the flip-install?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am having the same problem... I am running Ubuntu 8.04 and lsusb shows the device with the correct info but batchisp gives the same error. Also avr32program -l says noting. Did you ever get it to work?
Thanks,
Justin

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Fixed it! Atmel e-mail me and said

Quote:
Flip has been build to work on Red Hat distribution, for the moment we don't have a Ubuntu version available, but there is a work around.
The problem is batchisp libatlibusb.so reading stuff from /sys/bus/usb
and /proc/bus/usb but it is require to read /dev/bus/usb on ubuntu distribution.
Thats why your system has failed.

Solution:
---------
"hack" libatlibusbdfu.so in a HEXeditor by replacing the /sys/bus/usb -> /dev/bus/usb.

It works now and the changed file is available at http://embeddedmicro.com/main/downloads/libatlibusbdfu.so.zip

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You said you got it to work on Windows. Did you use AVR32 Studio?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Commanderbob wrote:

It works now and the changed file is available at http://embeddedmicro.com/main/downloads/libatlibusbdfu.so.zip

your link is down.

here is another link to this file
http://ubuntuforums.org/showthre...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I was following the advice in an earlier post to edit the usb device path in libatlibusbdfu.so with a hex editor and noticed what seemed to be an environment variable USB_DEVFS_PATH near the /dev/usb, /proc/bus/usb, and /dev/usb paths. So I decided to try setting it like so:

export USB_DEVFS_PATH=/dev/bus/usb

And voila! It worked without having to hack the file!

P.S. I'm using Atmel Flip and batchisp on Kubuntu 9.04