[solved] stk500 firmware upgrade in atmelstudio 6.2

Go To Last Post
19 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi all, 

 

 Good afternoon. This is sasi, I am using atmel sudio 6.2 and i am new to this. In this while doing "Device Progamming", I selected Tool:stk500, Device:Atmega128, Interface:ISP then appy. now i got an error "unable to connect tool stk500(com 21)".

 

Then i tried to do auto  firmware upgrade, in this i got "error:no programmer "

 

so, Then i tried to do manual  firmware upgrade

 

link is:

 

http://support.atmel.no/knowledg...

 

But in this i dont know  where the "PROGRAM" button. Please help me to find out the "PROGRAM" button and upgrade it.

 

  1. Push the 'PROGRAM' button while powering up the STK500

 

Thanks & Regards

Sasi

This topic has a solution.

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

Last Edited: Fri. Oct 10, 2014 - 09:56 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Most up to date documentation: http://www.atmel.com/webdoc/stk5...

 

However, I would guess that you either have selected the wrong com port, connected the wrong com port on the stk500 (there's 2, only 1 works) or you are using a usb<->serial dongle that messes up the signalling (most typically a found with older Prolific converters).

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi meolsen,

 

   in available tools it is showing stk 500 connected and then in add target it showing stk 500 and com21. after selecting these while doing device programming getting "error:unable to connect". 

  in upgrading c:/program files/atmel/atmelstudio6.2/tools/stk500 got an error "no programmer found". that AVR upgrade.exe is version of 1.0.3.0.

I dont know what to do. blank...

 

Thanks & Regards

Sasi

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi all, 

 

 Whenever try to do frimware upgrading always getting error "no programmer found".  what is this and where itr is Push the 'PROGRAM' button while powering up the STK500 - See more at: http://www.avrfreaks.net/forum/s...

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

stk 500 and com21

Try and move the come port down to 4 or less.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi js,

 

  Okay now i moved it to COM3. even now also getting same error. first time i am using atmelstudio 6.2.

 

ERROR:  unable to connect STK500(COM3)

 

Details:

Timestamp:    2014-09-10 16:09:22.718
Severity:        ERROR
ComponentId:    20000
StatusCode:    0

Failed to set-up tool (no context id returned).

 

for upgrading, view->available tools-STK500(COM3)Program only- connected, right click on this -upgrade -this sec itself connected is changed to In use and i got one window in that

1. power off the stk500.

2.Remove all cables and devices from target area of the stk500.

3.Hold down the "PROGRAM" button while powering up the stk500.

4.Press "OK" below.

 

In this point 3,  i dont know what is it and where is that "PROGRAM" button.

Please help me to find and upgrade it.

 

Thanks & Regards

Sasi

 

 

 

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

Last Edited: Wed. Sep 10, 2014 - 11:02 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

where is that "PROGRAM" button.

Near the 10 pin ISP header and the RS232 spare connector on the STK500.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

STK500 PROGRAMMER

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

HI JS,

 

   i am using the above STK500 programmer. In that there is no button. Now what i have to do.

 

Thanks & Regards

 

Sasi

 

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sasi,

 

I think the problem is that your programmer is NOT an STK500.

 

 

It may emulate the functionality of the genuine STK500, but it is not being recognised by the updating software.

 

Cheers,

 

Ross

 

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Valusoft,

 

  Thanks Valusoft. But I am not getting your point(problem is that your programmer is NOT an STK500.). could you please explain one more time.

 

Thanks & Regards

Sasi

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Sasi.

 

The original Atmel STK500 device (pictured) is not the same as your tiny clone. When the Atmel software is trying to update the software inside the STK500 it looks for things that tell it that it is really talking to the genuine STK500 and not a clone. Yours is a clone so it will not "answer the questions" being asked by the update validation software.

 

Is that clear now?

 

Cheers,

 

Ross

 

 

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Valusoft,    

 

Thanks Valusoft. Yes now i got it. my STK500 is tiny clone. so it is not answering while doing upgrade. Is there any other way to make it as work Clone stk500 in atmelstudio6.2.

 

Thanks & Regards

Sasi 

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Not that I am aware. But perhaps, some one else may know.

 

 

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi Valusoft,  

 

Thanks Valusoft for your great help. 

 

 

Thanks & Regards

Sasi 

 

 

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

If you own a clone,   never answer yes to "STK500 upgrade" request.

 

In fact,   if you ever get a "needs upgrade" message,    it means that your clone is crap.

Simply accept that your device will not 'work' with this software.

 

Most non-Atmel software will probably still work ok.   i.e. not give 'Upgrade' messages.

 

AFIK,   the genuine Atmel STK500 has had the same firmware since about 2007.

So any Indian manufacturer that does not "clone" accurately requires asking the Indian company.

 

They did not even make it look like the genuine Atmel STK500 !

 

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi David,

 

    Thanks david. Okay, now i got it what is the problem. 

 

 

Thanks & Regards

Sasi

 

   

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi all,

 

   Thanks to all who helped me to find out and understand the problem. Thanks to david, js,valusoft and meolsen.

 

Thanks & Regards

 

Sasi

-----------------------

Thanks & Regards,

Sasi

-----------------------

GO GREEN