serial (over usb) nonresponsive on atwinc1500 pictail

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There seems to be no clear answer about AT commands on current winc1500 FW (believe it is SDK v19.5.2, but since no response - I don't know)

 

what do i need to do to make this unit (or any atwinc) respond?

jeff

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

what procedure did you follow to set up the firmware ?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am not sure will AT command wrk on pictail, i tried it on winc1500 xpained pro board

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am trying to talk to serial port alone through US/UART.  I finally got it to take the START hex command.

 

<A5><01><F2><00><00><0C><00><0C><00><61><2F><52><EF>

(0)NO CORTUS app<0D><0A>
(0)(M2M)DriverInfo: None. Assuming 19.3.0<0D><0A>
(0)Chip ID = 1503a0<0D><0A>
(0)Flash ID = 1440ef, Size = 8 MBit<0D><0A>
(10)EFUSE:MAC<0D><0A>
(10)MAC_ADDR  = F8:F0:05:F4:1C:90<0D><0A>
(10)Shared buff static: 0, 5, 5, 22, 9, 10<0D><0A>
(20)NMI M2M SW  VERSION 19.5.2 SVNREV 14274<0D><0A>
(30)NMI MIN DRV VERSION 19.3.0<0D><0A>
(30)Firmware SVN URL branches/WIFIIOT-1660_19_5_2_RC7<0D><0A>
(30)Built at Jan 26 2017<09>22:13:34<0D><0A>
(40)ROM LIB VER_2<0D><0A>
(40)__AES_HW_ENGINE__<0D><0A>
(40)(M2M)LOAD SEC<0D><0A>
(50)(TLS)TLS Session Size= 1884<0D><0A>
(70)PSM_OFF<0D><0A>
AT+VER<0D><0A>
<0D><0A>
<0D><0A>
AT+CHIPID<0D><0A>

 

I assume from another post I ran across that AT commands are not supported any longer.

 

jeff