How to quit boot mode in Xmega A1U Xplained Pro?

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi, all,

I got a new Xmega A1U Xplained Pro board. When I tried to program it, Atmel Studio asked to update the firmware and I clicked update. However, the board is somehow entered in the bootmode. How can quit the bootmode and use the normal mode to continue my work? Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It should switch out of that bootmode once it has had a complete firmware delivered.

 

If it's just restarting in the bootloader mode every time it suggests the attempts to update the firmware are not running to successful completion.

 

Atmel have a command line tool to do the firmware updating as well as the Studio GUI method. You should try that as it apparently "tries harder".

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi

 

I know that your questions was long time ago. but I have the same probem and I couldn't found  the solution

do you remember how to quit the bootmode and use the normal mode?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Now it is even a longer time ago, but I haven't had the problem yet. 
What did you do to get it into "boot mode"

Mega16 w/ CV2.60/Studio6
Slo-Mo A>D/D>A

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi

 

Try to run the following in command line:

C:\Program Files (x86)\Atmel\Studio\7.0\atbackend>atfw.exe -a "C:\Program Files (x86)\Atmel\Studio\7.0\tools\EDBG\edbg_fw.zip" -t edbg

According to the webdocs you will see some warnings if it is already in boot mode, but hopefully it succeeds anyway.
http://www.atmel.com/webdoc/GUID...