ATSAMB11-MR210 with J-Link EDU

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I am trying to program/debug the ATSAMB11-MR210 using J-Link EDU.

However I don't have much success.

 

I connect selecting the MCU ATSAMB11GA18, the SWD interface and i tried different speeds (4000 kHz to 10 kHz).

The J-Link hardware can get the target voltage and control the reset pin. (I used the J-Link commander to control the reset pin to test)

 

I even used a logic analyzer to probe the SWD pins, it seems like the reset pin is pulled low and the reset commands are sent.

However the MCU does not respond.

 

The module is on a custom PCB.

 

Does anyone else have experience using J-Link with this bluetooth module?

 

Thank you.

This topic has a solution.

Pierre

Last Edited: Sat. Jun 24, 2017 - 06:47 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

 

Here is the IDCODE request from the J-Link

10100101 then turn around 1 and 1 0 0 ACK from the target.

However the target does not write anything after

I see the line reset bytes (56 bytes long instead of 50 like the SWD spec says).

 

Maybe SWD is protected and I need to do another operation first, however without any proper datasheet I don't know what should I do

Pierre

Last Edited: Thu. Jun 1, 2017 - 09:12 AM
This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So there is no problem at all with the J-Link EDU.

 

However the ATSAMB11 datasheet has a wrong footprint, I flipped the module and now SWD works like a charm.

Pierre

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Did you use any kind of custom configuration in order to make the SAMB11 to operate with J-Link?

J-Link does not have such device in its devices list and I am in a dead end! :(