atmel studio avrdude error

Go To Last Post
4 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hi, I'm trying to use Arduino using atmel, but I cant upload to the Arduino. I followed the instructors on this site:
https://medium.com/jungletronics...

but I'm getting this error:
avrdude.exe: can't open config file "C:\Program": No such file or directoryavrdude.exe: error reading system wide configuration file "C:\Program"

I'm using the following arguments:
-CC:\Program Files(x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM8 -b57600 -D -Uflash:w:"$(ProjectDir)Debug\$(TargetName).hex":i

How can I get this to work?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
C:\arduino\hardware\tools\avr/bin/avrdude -CC:\arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\giljr\AppData\Local\Temp\arduino_build_666279/_26_arduSerie_atmelStudio_00.ino.ino.hex:i

Did you use the above command, typed as one line like above?

 

Jim

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Try putting "quotes" around the path to the config file so that the space in the path does not get interpreted as the end of it. I.e.

-C"C:\Program Files(x86)\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega328p -carduino -PCOM8 -b57600 -D -Uflash:w:"$(ProjectDir)Debug\$(TargetName).hex":i

 

"He used to carry his guitar in a gunny sack, or sit beneath the tree by the railroad track. Oh the engineers would see him sitting in the shade, Strumming with the rhythm that the drivers made. People passing by, they would stop and say, "Oh, my, what that little country boy could play!" [Chuck Berry]

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

thanks, now its working. One other thing is it possible to change the argument for it to use the same ip that I sent in vmicro>Uploader>ip?