Atmel Studio 7.0.1416/7.0.1417

Go To Last Post
80 posts / 0 new

Pages

Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 3

It's that time of the year, the next release of Atmel Studio is finally done.

 

The readme/release note contains most of the info, so without further ado:

 

Note, that there's a big change in that we have moved all our older (2G) tools from Jungo to WinUSB. Hopefully this will resolve the ongoing issues with Windows 10 that are piling up.

 

We have also overhauled how DFPs interacts with the project system. It should now be more intuitive how to handle projects that are dependent on specific DFP versions.

 

For toolchains, there are new versions for AVR and ARM (yes, they are on their way onto the toolchain site as well, but with our new overlords there's some more hoops than usual, so bear with us while we work through that). 

 

AVR 8-bit GCC Toolchain 3.6.0 with upstream versions:

  • gcc 5.4.0
  • Binutils 2.26.20160125
  • avr-libc 2.0.0

 

ARM GCC Toolchain 6.2.1 with upstream versions:

  • gcc (ARM/embedded-6-branch revision 243739), GNU ARM Embedded Toolchain: 6-2016-q4-major
  • Binutils 2.27
  • gdb 7.12

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Last Edited: Tue. Mar 14, 2017 - 02:04 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks Morten.

 

Just to be clear... is this a patch... or a complete package that could be installed onto a virgin system? For example Windows 7...

 

Thanks,

 

Ross

 

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

It's complete, it will install on a clean machine and upgrade existing 7.0 versions.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Puhhh, and again the whole suite. I have 100MBit link but my workmate uses an expensive satellite link. He will love it :-)
"compiler.targets" was overwritten (of course) and my project ran out of bounds. Everybody who changed that should keep an eye on it.
Maybe I will try to write-protect it?!

Last Edited: Fri. Mar 10, 2017 - 04:02 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Good that we don't require people to upgrade then.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

in fact!
some of my friends even still work using studio 6.
(I love testing latests version ;-) )

Last Edited: Fri. Mar 10, 2017 - 04:08 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

6 minutes to download cheeky

 

Glad I recently switched to fibre!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What was all the microchip stuff that got downloaded thought?(something mplab related)

Last Edited: Fri. Mar 10, 2017 - 06:14 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

.... ah, you noticed that wink

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oops, I was trying to open a previous project based upon an AT90USB1286 and got the "Update pack, The project is referring to a pack that is not installed" window.

Clicking on the "Download and install" button gives me window "Pack Manager", "Downloading Atmel.ATmega_DFP.1.0.106.atpack" with an error message:

Error occured (sic) while downloading.

The remote server returned and error: (403) Forbidden.

Edit: I just closed the error message window and update pack window. AS7 appeared to load the project correctly. I did a clean solution and build and it says it built correctly... (Hmmm)

Last Edited: Fri. Mar 10, 2017 - 07:55 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

hmm, interesting... ATmega 1.0.106 is not listed as public (105 was) ... 

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have installed it on a Win7-32 Laptop.   Hoping that I would be able to use my JTAGICE-mkII again.

 

Result.   The Dragon no longer works.   The JTAGICE-mkII remains dead.

 

I will wait until we hear from a Win10-64 user before having two inoperable AS7 PCs.

 

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I see (in addition to 1.0.106) that versions 1.1.130 and 1.2.132 are shown in the drop down of the "Update Pack" window. Should I try one of these?

 

Edit: I had been using an older AS7 release (7.0.1006) and due to not wanting to upgrade in the middle of a project, I am just now upgrading...

Last Edited: Fri. Mar 10, 2017 - 08:04 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@frog_jr You can see the public list here: http://packs.download.atmel.com/

 

@david did you get any warnings during the installation? When you connect the Dragon, is it listed under Jungo or Atmel in the device manager? (aka what do you mean with 'does not work'). Also, search for AVRSV-7827 in the release note and see if that helps.

 

 

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Last Edited: Fri. Mar 10, 2017 - 08:06 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes,   I got a Warning about a Windows Update at the very start of installation.   Can't remember the magic number.    But the magic number did not appear in the optional Updates,   so I could not see how I could access it.

 

When I start AS7,  I get a Usage Experience Failure on the first attempt.    Whatever that might be.

 

AS7 shows Simulator.   No mention of Dragon or JTAGICE-mkII

Device Manager just shows Other Devices->Unknown Device

 

I plugged an XMINI-mega168pb which seems to be recognised and remain Connected.   It appears in Device Manager under HID and COM.

 

The Dragon used to work with AS7.0.1188 (or whatever the previous Release was called)

The JTAGICE-2 has never worked with any AS7 version.

 

David.

Last Edited: Fri. Mar 10, 2017 - 09:50 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In the DFP pack list why are they not sorted?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

JoniS wrote:

What was all the microchip stuff that got downloaded thought?(something mplab related)

 

meolsen wrote:

.... ah, you noticed that wink

 

Morten, care to expand on this?  I am not having any issues with teh version of AS7 I am using at times, and I already have all the MPLAB stuff so what has been 'embedded' that I might already have and do not need a second installation of?

 

Jim

If you want a career with a known path - become an undertaker. Dead people don't sue! - Kartman

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

David.Prentice said:

I will wait until we hear from a Win10-64 user before having two inoperable AS7 PCs.

I have both my Dragon and JTAGICE-2 working in Win10-64.  Well, they are appearing in Device Manager and Atmel Studio at least.  I didn't try programming or debugging.  (See bottom of post.)

 

The proof is in the pictures:

 

 

 

 

 

 

EDIT:  Using the Dragon, I successfully read the fuses and programmed the flash on an ATmega1284P plugged into a breadboard.  A firmware upgrade was not necessary!

 

Greg Muth

Portland, OR, US

Xplained Boards mostly

Atmel Studio 7.0 on Windows 7 VM hosted by Ubuntu 17

 

Last Edited: Sat. Mar 11, 2017 - 04:31 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

 

@meolsen: Are the Jungo Drivers (see above) still necessary?

 

Greg Muth

Portland, OR, US

Xplained Boards mostly

Atmel Studio 7.0 on Windows 7 VM hosted by Ubuntu 17

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Greg_Muth wrote:
The proof is in the pictures:
May you winver?

Thanks!

 

Why :

http://www.avrfreaks.net/forum/atmel-ice-known-good-computer-and-os

How :

InfoWorld

Woody's Win10Tip: How to figure out your Windows 10 version

by

Nov 1, 2016

http://www.infoworld.com/article/3136336/microsoft-windows/woodys-win10tip-how-to-figure-out-your-windows-10-version.html

Your Windows 10 version -- build, Home/Pro, bit count -- controls much of your Windows life. Here's how to see where you are and where you might be headed

...

To see what version of Windows 10 you're using, go down to the Cortana search box (to the right of the Start icon), type the following:

winver

Then press Enter. You see the About Windows box for your machine.

...

Unfortunately, the About Windows box doesn't tell you for sure if you're running the 32-bit version or the 64-bit version of Windows 10. If you want to know the "bittedness" of your machine, you need to dig deeper. Click Start, then the Settings wheel. Choose System, then on the left choose About. You see the full details in the screenshot.

...

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So, the MPLAB stuff is just a part of their USB stack. In the case for the change from Jungo it's just a thin wrapper on top of WinUSB.

 

 

As for the Jungo/WinDriver node, no it is not longer neccesary for Atmel Studios part. However we will not remove existing Jungo drivers, as that would interfere with for instance IAR and older Studios etc. If you don't want it anymore you can uninstall it in Add/Remove programs.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote: May you winver?

 

Yes:

 

Greg Muth

Portland, OR, US

Xplained Boards mostly

Atmel Studio 7.0 on Windows 7 VM hosted by Ubuntu 17

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@David I have uploaded the inf files here. Could you try to update your Dragon driver by pointing to the inf file in this zip?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I unzipped and copied the directory to:

C:\Program Files\Atmel\Studio\Drivers\inf\winusb\atmel_winusb-8.0.13

 

and pointed to this directory which contains the INF and DLL and CAT files.

 

I just get: "Windows was unable to Upgrade my Unknown Device"

 

-rw-m   28012 06.02.2017 08:34:30 C:\Program Files\Atmel\Studio\Drivers\inf\libusb0\atmel_usb_dfu\atmel_usb_dfu.inf
-rw-m    8790 06.02.2017 08:34:30 C:\Program Files\Atmel\Studio\Drivers\inf\ports\atmel_debuggers_cdc\atmel_debuggers_cdc.inf
-rw-m   16698 06.02.2017 08:34:30 C:\Program Files\Atmel\Studio\Drivers\inf\ports\atmel_devices_cdc\atmel_devices_cdc.inf
-rw-m    9380 06.02.2017 08:34:30 C:\Program Files\Atmel\Studio\Drivers\inf\winusb\atmel_winusb\atmel_winusb.inf
-rw-m    9380 06.02.2017 07:34:30 C:\Program Files\Atmel\Studio\Drivers\inf\winusb\atmel_winusb-8.0.13\atmel_winusb.inf
-rw-m    2440 13.10.2015 08:27:02 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb32\atmelwindrvr_driver.inf
-rw-m    2344 12.08.2015 10:18:00 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb32\windrvr1200.inf
-rw-m    2394 28.01.2014 06:59:44 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb32\windrvr6.inf
-rw-m    2440 13.10.2015 08:30:40 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb64\atmelwindrvr_driver.inf
-rw-m    2344 12.08.2015 08:50:42 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb64\windrvr1200.inf
-rw-m    2394 28.01.2014 06:59:44 C:\Program Files\Atmel\Studio\Drivers\Jungo\usb64\windrvr6.inf
-rw-m    5941 08.01.2015 15:06:24 C:\Program Files\Atmel\Studio\Drivers\Segger\CDC\JLinkCDC.inf
-rw-m    2234 08.01.2015 15:06:24 C:\Program Files\Atmel\Studio\Drivers\Segger\x64\JLinkx64.inf
-rw-m    2163 08.01.2015 15:06:24 C:\Program Files\Atmel\Studio\Drivers\Segger\x86\JLink.inf

My Win7-32 LapTop started with an empty SSD.   It has only ever had AS7.0 installed since the Win7-32 OS was installed last year.

 

David.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

And if you try the inf from here, does that help?

 

If not, could you PM me your setupapi.dev.log file (from %WINDIR%\INF\setupapi.dev.log).

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So, first driver issues seems to be reported. This only happens on 32-bit Windows and on tools that were previously using Jungo. The inf here seems to fix the issue. (At least it worked for David). Will come back with more info as I know what is going on.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Last Edited: Sun. Mar 12, 2017 - 09:07 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We have had a discussion internally, and we have decided to release a fix for the USB issue. We're working on this now and should be done in a couple of hours.

 

Note that due to reasons, the fix will download ~80MB when upgrading from build 1416. It is however not imperative to upgrade, as the only change is in the USB drivers for 32-bit Windows. Everything else is the same.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Build 1417 went online a couple of hours ago. This contains the fix to the 32-bit USB issue. Nothing else was changed.

 

I have updated the original post with new links.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I was fairly happy with the  previous 6 minutes to download but it was actually the best part of an hour for the installation to complete that really did for me. Please tell me this is the "final" version for now? surprise

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

the 1416 release works great for me and I do not see any reason to apply this upgrade.
As I understand there are no changes at all except the driver-fixes for 32-bit windows if Jungo-drivers were used before.
64 bit WIN here and everything fine.

My JTAGICE3 also works after a firmware-upgrade.
 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, the only change is for the drivers on 32-bit Windows. There is absolutely no need for those that updated to 1416 to update to 1417 unless they want to smiley

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I was able to repair that error by unpacking the .16 Zip that meolsen uploaded, and copied them in the address mentioned by David, then I simply closed AtmelStudio and reopened it, and it worked !, my AVR ISP MKII is alive again smiley

Thanks Guys yes

While (Jandcan->_status == ALIVE){

           figth(&Jandcan);

};

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Morten,

 

is there also an offline installation available?

Also on the Atmel website the version seems to be 1188.

 

got a machine that I rather not have on an internet connection (testing machines that also are dependent on what windows updates are installed or not, and we have found out that every now and then windows does updates even though we disabled them) and that are in a highly restricted zone, so getting them on an internet connection is something that the higher management does not allow/want. till now I could just take my usb stick have it gone through all the procedures and then install the new version of studio.

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Switch out -web with -full in the url above to get the full installer.

 

However we also allow the creation of 'custom' offline installers from the web installer (i.e you can choose the content of the installer), by passing -layout to the webinstaller. This means that you can in effect remove Architectures. This option is mostly used when deploying on networks etc, but I find it helpfull :) 

 

We are working on updating the website. Getting there soon wink

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We have 2 Dell laptops with Windows10 x64, had Atmel Studio 7.0.1188 working with SAM-ICE (Segger), but after upgrading to 7.0.1417, one of them doesn't see any programmer device, not even EDBG from SAME70 Xplained boards. We uninstalled all Atmel drivers from Programs & Features, reinstalled AS7, without success to get it working again. The J-link driver is listed in Devices Manager without exclamation marks. Any idea what's wrong?

 

Best regards,

David. 

Last Edited: Wed. Mar 15, 2017 - 11:49 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Can you see the Simulator in View->Available Atmel Tools?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We went back to 1188 on that system which is working so I will come back to you in a few days once we can give it another try.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So, I have a new WIN10 64 bit machine. Just tried the webinstaller on the Atmel site 1188, but it seemed to take forever. All the bars were complete, so I cancelled not knowing what was stuck or what.

No useful info on the install screen, just spinning circles  and I don't know where the install log went - can't find it now having closed it.

The install log showed many attempts at accessing the files on amazon servers failed so I downloaded the offline installer.

 

 

Checked here before launching it and see the 1417 build.

Here we go .. with 1417

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have installed just last night AS7 on a laptop, if you click on details you should see the downloaded file and size, it was very slow, for me took about 2 hours. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Installed .. 1417

Load existing AVR project

Get message - This project is referring to a pack that is not installed  Missing Version 1.0.106

... ATmega_DPF  ( Installing pack, please wait )

 

... Downloading... Error occured while downloading

The remote server returned an error (403) Forbidden

 

Please advise.

( What is a DPF anyway ??) 

Thanks

Last Edited: Wed. Mar 15, 2017 - 03:15 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We're working on that, just choose another version in the drop down...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK. Thanks.

Gone into DPF manager and installed everything relevant.

Project loads now.

 

I don't recall ever having to do anything with these DPFs before in my old Win 7 Studio 7 machine. From memory it just worked  - but that was a while ago .. may have forgot.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Just open the list and select DFP in version 1.2.xxx instead of the "new update available" 1.0.90, that gets the error 403.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We have now updated the server with the 1.0.90 and 1.0.106 ATmega DFP

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I have the 1417 build installer but the Studio 7.0 won't start. It crashes when I launch it and asks me to debug or close application. The error message simply says 'Atmel Studio 7.0 has stopped working'. Please help resolve this. I have Windows 10.

 

Regards

 

Last Edited: Fri. Mar 17, 2017 - 03:21 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Please contact support so that we can obtain the needed crash information.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:
Please contact support so that we can obtain the needed crash information.

 

Is this it - http://www.microchip.com/support... ? Or something else? Sorry, I'm just starting out. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Try http://www.atmel.com/design-supp... and then Open support case.

 

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

By the way, where has Percepio Trace gone in Atmel Studio 7.0.1417? It is not there anymore after update, and it does not appear in the Extensions either.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

I'm running the 1417 under Windows 7. Installation worked, it compiles, but my GUI stucks about every 5 seconds for about 1-2 seconds. This is very annoying, a continuous workflow is nearly impossible (the complete Atmel Studio is affected). Did anyone else encountered this problem so far? The last Atmel Studio (1188 for me) worked fine.

 

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Over-active antivirus?

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Pages