Atmel Studio 4.19 in Windows 10?

Go To Last Post
15 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just got a new Windows 10 computer and am in the process of setting up all my dev environments.

 

All my AVR work has been done for many years in assembler on AS4 and although I've tried the later versions several times, I've always found AS4 to be really quick and easy to work with.

 

But I can't get my AVRISP MKII to work.

 

The old driver that comes with AS4.19 refuses to work at all. I tried installing AS7 and the driver appears okay in Device Manager, but AS4 can't see the AVRISP MKII.

 

Do I finally have to bite the bullet and learn AS7?

 

This topic has a solution.
Last Edited: Wed. Apr 12, 2017 - 02:50 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

As 4.19 indeed runs on Win10....at least on my win10 machine.

You may have to do some driver gear shifting though if you have AS7 and AS4.19 on the same machine. There is a sticky I think on this

Jim

If you want a career with a known path - become an undertaker. Dead people don't sue! - Kartman

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

jgmdesign wrote:
As 4.19 indeed runs on Win10....at least on my win10 machine.

 

Thanks for the reply Jim. I've just been playing with AS7 and it has so many graphics problems to be unusable, so I'm happy to hear there is some hope for AS4.19.

 

Quote:
You may have to do some driver gear shifting though if you have AS7 and AS4.19 on the same machine.

 

I don't understand what you mean.

 

Quote:
There is a sticky I think on this Jim

 

Do you mean this?

http://www.avrfreaks.net/forum/a...

 

I've been reading it but having trouble understanding where to get the drivers. It isn't helped that some of the links don't work.

 

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I think the latest driver bundle before the incompatible Jungo change is driver-atmel-bundle-7.0.888.exe. So far it seemed to work everywhere for me (from XP to Windows 10, from 4.19 to relatively recent 7.x).

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ezharkov wrote:
I think the latest driver bundle before the incompatible Jungo change is driver-atmel-bundle-7.0.888.exe.

 

Thanks for the reply. I tried to download it from:

https://gallery.atmel.com/Produc...

 

and get this error:

Quote:

An error ocurred:

 

You can only purchase the current release. Please refresh the product info and try again

 

Any idea where I might be able to get it.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No idea what that means. Maybe Morten will see this and shed some light. Here is my copy of it: https://www.dropbox.com/s/3lskki...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm not having a lot of luck today:

 

Quote:

Restricted Content

This file is no longer available. For additional information contact Dropbox Support.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I cannot download it either. And of course, the old links to atmel.force are no longer working. What a mess!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There was an article about downgrading on atmel.force. It looks it got moved to microchip.force: https://microchip.secure.force.c...

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This one: https://gallery.atmel.com/Produc...
Didn't tell me to "You can only purchase the current release".

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

ezharkov wrote:
This one: https://gallery.atmel.com/Produc... Didn't tell me to "You can only purchase the current release".

 

Problem solved!  Thank you! :-)

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike Warren wrote:
The old driver that comes with AS4.19 refuses to work at all.
Though for STK500 use instead of an AVRISP2, there's mention of a driver in

http://www.avrfreaks.net/forum/studio-419-build-730-windows-10 by scottm

Might try the drivers in Zadig for further attempts :

http://www.avrfreaks.net/forum/avrisp-mkii-and-jtagice-mkii-windows-10-not-working-after-fresh-install#comment-2074641 by Gerry_78

Mike Warren wrote:
Do I finally have to bite the bullet and learn AS7?
No but be cognizant that WinUSB changes in Windows 10 are common; once you have a Windows 10 build that works, copy it.

 

Edit : glad you solved the problem!

 

"Dare to be naïve." - Buckminster Fuller

Last Edited: Wed. Apr 12, 2017 - 02:54 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

jgmdesign wrote:
You may have to do some driver gear shifting though if you have AS7 and AS4.19 on the same machine. There is a sticky I think on this
http://www.avrfreaks.net/forum/downgrading-tools-use-older-jungo-driver by js

corrected in http://www.avrfreaks.net/forum/atmel-studio-419-windows-10#comment-2136021

 

"Dare to be naïve." - Buckminster Fuller

Last Edited: Wed. Apr 12, 2017 - 03:07 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yeah one of these days I will drink the kool aid and allow the update to go through.

Jim

If you want a career with a known path - become an undertaker. Dead people don't sue! - Kartman

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Mike Warren wrote:
I've just been playing with AS7 and it has so many graphics problems to be unusable

You can possibly solve this by stabbing registry, I had similar proplems when there was some bug with my videocard drivers and software rendering was not automatically switched on.

http://www.avrfreaks.net/comment/1843791#comment-1843791

Last Edited: Wed. Apr 12, 2017 - 04:05 AM